Helicopter spins (yaw) when trying to take off

Hello all!

I have been slowly making progress on getting my 800 traditional heli to fly. It has a pixhawk2.1. I’ve gone over a lot of the set up with Chris Olsen a month or two ago in a separate post.

I have recently tried to get the heli in a low altitude hover for tuning purposes. I had it set to stabilize mode. Once I have spooled, I increase collective slowly. When I am nearly leaving the ground the heli wants to rotate (yaw). See this video.

I am being quite cautious. Is this something that should happen with the autopilot? (I would think not!) Is it a poorly calibrated compass? Or is there some parameter I should be adjusting?

Thank you,

It’s not something that should happen. You could have the rudder servo reversed. Or several other things could cause it. Seeing a parameter file exported from the flight controller would help. As would the log from the microSD card for that particular takeoff attempt.

Okay. I am out of town right now for the next 10 days or so. Once I’m back I will post them.

And I’m finally back!

Here are the Setup_v1.param (13.7 KB)
and log1 and log2 files. I had been playing around with settings and did a few tests.

The GPS wasn’t working so I ended up disabling it/ignoring it. I was just trying to get a stabilized flight/hover in.

A couple possible problems I see. I doubt these yaw settings will hold the tail on a 800-class machine. I would suggest getting the VFF up to .11 or .12 and the yaw P to at least 0.25

The other thing is, I see your tail servo maxing out at 850 every time you try to lift off. First verify that the servo is going the right direction with stick input. But secondly, are you sure only 270 pwm is giving you full rudder travel? That doesn’t seem likely.

Judging by how the servo is maxing out at 850 at liftoff, I don’t think you have enough rudder travel in the anti-torque direction to hold it. Verify that SERVO4 max and min is set to what it takes to almost bottom out the slider in both directions.

Hi Chris,

Thanks again for the input.

Checking the servo4 range again it seems like I must have tuned it wrong. I think I thought the servo was binding and it wasn’t. The new servo range is: Min = 590; Mid = 750; and Max = 947. A range of 357 now. Does this sound better or does it still seem low?

I believe I had the VFF and yaw_p set to the values you suggested before, but had played with them between the video I posted and now. I’ve reverted back.


Yes, that range of 357 sounds more reasonable than only 270 pwm. I don’t think the helicopter had enough rudder authority before to counter torque.

So I finally had some decent weather and got out testing.

I am still having the same issue when taking off. The helicopter doesn’t seem to spin as aggressively but it is still spinning. I used the updated servo ranges and if I am looking at the right variable in the logs, the tail servo still maxes out. See attached log file.

Since I am running at lower head speed than the heli’s typical use, is it possible my tail rotor cannot counter the torque? I know it’s possible to change the tail rotor to a 3-blade setup. Or do you think it might be something else I am not doing correctly? If I have a clockwise spinning main rotor, the tail rotor should be coming up into the down wash of the main rotor; correct?

Thanks again for any help!

That is usually the correct way, but it doesn’t make a lot of difference. I’ve built them both ways and it still works.

If it continues to bottom out the tail servo I’m guessing the problem is too much torque, not enough tail. 3 blades might help. Stepping up the headspeed so it pulls less pitch gives a better L/D ratio on the main rotor and produces less torque. And also speeds up the tail rotor and gives it more authority. That is the recommended way to “fix” it.

Otherwise you can change the gear ratio in the tail drive box to speed the tail up, put bigger tail blades on, or try a three-blade tail rotor

Hi Chris,

I have tried different head speeds. I picked up a tachometer to confirm them. I got up to about 2100rpm and still had this issue - it did seem a bit better though.

I guess the next step would be trying a different gear ratio for the tail or adding a third blade.


Typical tail drive ratio is 4.5 to 4.7. Do you know what yours is?