Heli swash doesn't move, help please!

Hello alll,
Last week I tried to set up Align Heli 500 with Arducopter 3.2.1 Heli. The setup went smoothly, but when I tried to check the RC stick controls, only in stabilize and acro modes I could move the swash with RC sticks. In other modes the swash doesn’t move at all. I tried many mode changes but with no avail. In Stabilize and Acro modes, the swash moves accordingly to the stick position, in other modes, the swash seems to reset when mode is changed, then stops moving. Can anyone give me an explanation? Any help is highly appreciated.

I got similar problem with you and my swashplate does not move in all modes.

The servo I am using is WK-7.6-6.

Does anyone has some advice?


Try by pushing the arming switch and then initialize the controller then go to mid stick on your collective (hover point) and try switching modes.
What controller are you guys using??

Blades off or motor unplugged of course…

I’m using APM 2.6, now I think I’ve solved the question. The stabilize and acro modes can move swash in both armed and disarmed states. But if you arm the heli in other modes, you can’t move the swash. Then you change to stabilize or acro, you can move swash. Then if you change back to previous mode you can now move the swash. This situation may occur only on test bech, in the reality, you often arm the aircraft in stabilize mode and then take off. In this case, you always can move the swash with RC sticks.

I did check mine last night as I was not sure as to the way I did it, I do not initialize the pixhawk but I do push the arming switch so it is solid red.
And avionics battery pack is plugged in, just not the flight battery…
Also I believe you need to have a gps lock (low HDOP) in order for auto modes to work, this can be hard when your testing inside.
Hope this helps :slight_smile:

But I cannot move the swashplate in all kinds of modes.

The helicopter frame I am using is Master CP.

I just replace the receiver and changed it to APM.

I can do all the calibrations but the servos just do not response to the controller.

Is WK-7.6-6 servo compatible with APM

Thanks for you advice