Heli jumps up/down about 3 inches

Just fleww. heli jumps un and down about 3 inches in Pos Hold mode, otherwise stable. After flight, noticed Mission Planner Altitude and Airspeed are jumping with heli on my desk!

You need to:

  • update to arducopter 4.2.2
  • reduce vibrations a lot,
  • tune the notch filter,
  • tune the PIDs,
  • tune the wind estimation
  • Use RTK GPS in RTK mode

and then it will no longer jump.

Are you willing to do the work?

I looked at the .bin after flying.
Has 4.2.1. Updated to V4.2.2 using QGC.
Checked and found minimal vibration in all three axis.
Notch filters were 0, now set to 1, enabled.
I reset:
ATC_ACCEL_P to 42300
ATC_ACCEL_R to 42300
ATC_ACCEL_Y to 20000
ATC_ANG_PIT to 4.4
ATC_ANG_RLL to 4.3
ATC_ANG_YAW to 4.5

The jumping is gone. Now there is some cyclic wobbling. Toilet bowling.?

Two questions, Initial Parameter settings. How change “rotor size” It is a 450 class. And uses 3 LiPo cells. MP always shows 9 inches and 4 cells. How change/correct. I entered the correct values. 3 LiPos and 28 inches. Disconnected and reconnected. Old values returned. Every time!

The “Mission Planner - mandatory initial parameters settings” is just a wizard, execute it just once!
Because it is a wizard it always start wit some default values and does not store the data that you input to it. It just stores the data derived from that.

Execute it just once and you will be fine!

If the power does not fail, you will not brick the board by updating the bootloader.

Look up the documentation on tuning the “dynamic notch filter”

Please explain.
What wizzard.

see reply above. And start reading the docs