Had to re-flash firmware after copter triggered missing terrain, why?

Hello, i was flying my copter as I always did for a long time, and suddenly I lost telemetry and after a few minutes the copter landed by it self.

I can’t figure it out why it lost telemetry in middle of flight and after landed by it self, and after land I wasn’t able to connect cube on mission planner even using usb cable (its like cube bugged on start up and never finished it, becouse my esc never stoped beeping, GPS light didnt turn on) after this, and the only way I found to connect, was flash copter 4.0.7 again and after that I was able to connect by usb or telemetry.

I did more than 30 hours of flight in this copter and nothing ever happened.

*I’m not using 4.1.2 becouse it has (unsolved) problem with my lidar and mission speed (never goes higher than 7m/s, even if I set).

Log: https://drive.google.com/file/d/1DG2NgcmMiv6LpfqoL4uJuiG7KMdw1r3S/view?usp=sharing

Just a wild guess, but that seams like a power supply issue.

If was a power issue, copter should crash not return to launch.

And if was power issue, I should be able to connect after fixing this issue, right?

I looked at your flight log, it did RTL because of missing terrain data.
Also you have many radio failsafes during auto flight but root cause of RTL is missing terrain data in your case.

Well, it could be, I saw on log a weird measure from my lidar but now is work perfectly, do you have a clue Why my lidar has failed?

But it still missing one question, why after RTL trigger I completly lost telemetry and I wasnt able to connect with FC, even using cable, until I re-flashed The firmware?

I could not be able to see any indications related to your problem in your logs, after failsafe (RTL) no connection (or trying to connect) between GCS and vehicle. Could be a hardware fault, are you sure your connections (telemetry cables) are good?


Are you able to reproduce this multiple times?

Well, it could a hardware fault, this cube is 1 year old I think. Right after not be able to connect, I re-flash the firmware and the problem was solved, so my cables was ok, becouse I didnt disassemble the copter before re-flash.
After fixing this issue, I’ve desassembled the copter to check my connections and one wire telemetry and lider bec supply was fault so I fixed it and this was the main problem of terrain failsafe.

No I can’t, I didn’t test the copter after fixing, I hope this error never occur again.

The interesting part was that I tryied many times to connect using cable and mission planner wasn’t receiving heart beats.