Gremsy T3 pixhawk cube

Anybody running this gimbal? Does mavlink actually work? I’m assuming i still need control, so aux outs, or possibly SBUS out? Its marketed as canlink, it isn’t. supposed to run mavlink, so far, no. My tarot t3diii ran fine off aux 1 and 2. i may have to try more aux ports, and a PWM encoder to the gimbal. but this is very much not as advertised…

@HUY_PHAM is the Gremsy guy and might be able to help.
I’ve been intending to follow up on the canbus implementation so perhaps he can update us all on that too.

The cable that gremsy calls the pixhawk can cable is a serial connection. Not canbus at all. they say it works over mavlink, but all ive gotten it to read is sbus. No success from searching either. I just got SBUS out almost working on my hex carrier board, but only with the servo pins loose, if i push it down, i lose signal. Suspecting a weak solder, i’ll inspect and reflow it tomorrow. This gimbal was marketed to work, and i had FAR more success with alexmos, tarot, and storm32. feel like i wasted 1500$…

Follow up, SBUS out works great. But only after you press the magic button.

it works great over mavlink serial, but you need to put the right firmware on the gremsy
Their Facebook page has a lot of knowledgeable people on it

Confirmed via gremsy, mavlink control only partially functioning. Pan, tilt and roll control only. Since mode switch isn’t supported, other control input is required. Got SBUS out running, and full gimbal control.

But now the bird doesn’t fly.
After getting the gimbal running, on the maiden, she played turtle. Immediate flip right. Motor order went crazy.

No wiring was changed. Parameters all set for octa x. Motor out going to correct servos, Etc.

Motors are wired as documentation says.

Clockwise from front right, (motor 1).


Motor test should occur clockwise from motor 1.

Motor test is clockwise from motor 1.


So motors 1 and 5 are correct. The rest is craziness. I tried to wire to match the motor test, and got some form of flight. Throttle control, pitch, and roll control, but no yaw. I can hear motors spooling up, but absolutely no yaw control.

So full collection if issues currently.

Windows 10 laptop can’t flash board anymore. But can communicate through mission planner, and motor order issue.

Going to reset my laptop. I think it’s a windows side problem. I’m hopeful that a bad flash is caching somewhere.

Any other ideas?

Do you have working “horizon drift correction” when Gremsy T3 is connected via com 2 to telemetry port of Cube Black? I know that I have to set SERIAL_BAUD to 115 and SERIAL_PROTOCOL to 2 . What about SR parameters like SRx_POS SRx_ADSB SRx_RAW_SENS ? They will be set automatically ?

I never got mavlink working. I just use sbus out. I don’t see the point of running mavlink until its complete. After swapping out some bad hardware, everything is functioning.

I don’t need to control gimbal by pixhawk. I just need horizon correction from pixhawk.

I get from Gremsy such short manual. Bu there is no info about more settings…

Gimbal connect to Pixhawk_V2.pdf (590.9 KB)

Gremsy t3 doesn’t work with arducopter

Have Gremsy confirmed that?

They just wrote me that it’s beta firmware and that I have to check options which I checked.I will try to figure out what is wrong when I will have same more time.

Ok, thanks. I’ll reach out to them again too.

T3 does work with ardupilot.

and horizon correction working ? How did you setup SRx values ?

Dear all,

I tried T3 with Cube with serial connection.
This is the first try. It seems well.

But in the second try,
T3 gimbal started to rotate suddunly.
And attitude control was disturbed.

I want to check the Message to T3 and T3 status by Flash Data from Cube.
Which parameter should I look at in the flash data?

Why did you fly without camera in this second video ? Gimbal should be balanced before turn on. Do you think that gremsy disturbed flight controller (pixhawk) ? That looked scary.

1 Like

The reason I did not mount the camera was because the camera was on a different UAV , and it was the first test flight at this site.
I did test flight without the camera to prevent it from crash.

I don’t think the gimbal’s motion had had a significant effect.
I want to check if gimbal was not controlled by MavLink.

Gimbal will not work if it’s not balanced and there is no camera.

1 Like

Thank you.
I’ll test with camera next time.

By the way,
Can I check the Message to T3 and T3 status by Flash Log Data from Cube ?