Servers by jDrones

Gremsy Pixy U Ardupilot Serial Connection

The Gremsy Pixy U Gimbal has a Pixhawk serial connection which is designed to allow control of the gimbals Pitch, Roll, Yaw and Gimbals Mode (Follow/Hold/Motors On-Off) channels.
While the Pitch, Roll, Yaw channels work the Mode does not and the gimbal is stuck in Hold Mode.
Gremsy have said this due to an Ardupilot coding issue and they are working with the developers to get a fix.
Could someone update me if this issue will be resolved in the near future?

1 Like

Hi @Peterarnold,

So yes, I’ve also been chatting with the people at Gremsy and they told me about this issue and I’m planning on a fix for Copter-4.0.x (not sure which point release it will go into).

I’m glad you’re here so I can directly ask you about the details. I’m wondering a bit about where these gimbal modes (Follow, Hold, Motors On/off) are showing up. I normally use MP and I see a different set of available modes.

In any case, I think there are at least two things we need to fix/enhance in AP:

  • Add an auxiliary switch option to allow the user to return the gimbal to “RC Targeting” (i.e. where some of the transmitter inputs control the gimbal)
  • Add a new mode that allows the user to specify that the yaw control is relative to the vehicle. At the moment with a 3-axis gimbal (including the Pixy U) I think once the user is controlling the angles of the gimbal the yaw is always earth-frame. This means that if the vehicle rotates the gimbal rotates in the opposite direction so that it keeps pointing at the same object on the ground (or wherever), in ArduPilot speak we call this “earth frame”. I’m thinking we should add another mode so the gimbal’s heading would rotate with the vehicle’s heading. For reference in AP we call this “body frame”.

What do you think?

Hi
Thanks for following up with this!
I think your suggestions are good and you are in a far better position than me know the best way to address this.
For me and reading the Gremsy Pixy U manual I thought I could use a serial connection (cable provided) to connect the Pixy U to a Cube then after setting up the appropriate RC channel use my Taranis X9D to control the Pixy U Pitch, Roll, Yaw, and Modes. Each of which would be on a separate channel. The Taranis slider switches worked with the Pitch, Roll, and Yaw channels. The mode channel was assigned to a 3 position switch. The modes are High (2012) - Follow mode, Middle (1500) - Lock Mode, Low (988) - Motors off. This 3 position switch did not work and the gimbal stays in the middle or Lock mode and is the problem.
I bypassed the Cube with a SBUS connection direct from the RX to the gimbal’s SBUS input and the 3 position switch works and the modes can be changed.
I’m not sure if the above helps but obviously the 3 position switch value is not getting through. I have the Flight Modes on a 6 position switch and maybe something similar that is user defined and can be assigned to a channel could be helpful?

Just checking if there is any updates on this, I have Roll, Pitch, and Yaw working through the serial cable but can’t get Mode to work?

No change to my knowledge :frowning_face:
I am using SBUS out from the cube to the Pixy U in the meantime.

Thanks Peter, I guess I’ll have to switch it over to sBUS

I did this way.
Connect a cable from the Cube ‘SBUSo’ pins to the Pixy U SBUS in pins
Enable the SBUS Out pins by setting the parameter BRD_SBUS_OUT = 1.
Set each servo channel used to passthrough so the RC signal get passed straight to the appropriate AUX pins unaltered.
e.g. for Channel 12
SERVO12_FUNCTION = 1 (RCPassThru)

1 Like

Hi Peter,
Thanks, I have it working except the “Right Click in MissionPlanner, Point Camera here”, doesn’t work for me.
Is it working for you?
Thanks
Doug

Hi Doug
As I understand it, if you have SERVOxx_FUNCTION = 1 (RCPassThru) the signal from the RC transmitter will pass through the Pixhawk unaltered and go directly to what you have connected to on that Servo channel. Pixhawk or Mission Planner commands will be ignored.
To allow the Pixhawk to control the gimbal try changing SERVOxx_FUNCTION to 6 (mount_pan) or
7 (mount_tilt) or 8 (mount_roll). This should allow the Pixhawk to control the gimbals Pan, Tilt and Roll axis. Mount I think refers to the gimbal. You may have to have the gimbal in Lock mode to get Mission Planner to Point the camera. I haven’t used the gimbal in this way so let me know if it works?
Cheers.
Peter

1 Like

Thanks Peter, I’ll give that a try this week and let you know.

I also met this issue, where pixy u is stuck in earth frame. why is this an ardupilot issue ? I have a small tarot gimbal for gopro, yaw follow body frame, while I can still control it with pwm. Also, once you set storm32 mavlink with pixy u, I can’t connect to the drone using a companion computer via dronekit, looks like multiple gcs ID or some issue like that. let me know if I can help you with testing anything.

Servers by jDrones