Servers by jDrones

GPS stop working


(Erik Skovbjerg) #1

I have for some days tested Copter 3.5.0-rc9 with following problem.

When I loaded ver 3.5 into Pixhawk is’t working fine, Load done, calibrating done
Next day I do autotune, well done no problems and a short test fly. No problem so far.
The I restart pixhawk, no GPS signal for next 1 hour, tried several thing, new GPS, same problem. The drone was put away for next day.
Next day I start the pixhawk fine GPS signal. Hmmmmmm… After 10 min no GPS signal and for rest of the day.

Today I got the pixhawk out again, this was staying in 15 deg temp. Outdor temp was 20 deg. Now I restarted every 5 min. After 25 min no GPS signal, cont restart next 30 min, same problem. Hmmmm…
Reloaded without restart, version 3.4.6, restart Pixhawk, wupti GPS was bak, and I have now tested for 2 hour and it’s starting every time…

Pixhawk is ver 1
Look like there timing problem in 3.5, when Pixhawk got some temperature…


(Luís Vale Gonçalves) #2

You don’t say which GPS unit you’re using.

Also on the messages window of Mission Planner check for the GPS related messages


(WickedShell) #3

I’d check your cabling/old logs. It’s very possible your GPS has a loose connection on the Tx pin from the Pixhawk to the GPS, which is prohibiting us from configuring the GPS. Before RC9 it would fall back to NMEA mode, however this is not configured correctly, and starves the EKF of information it wants, as well as possibly being the wrong baud rate.


(Erik Skovbjerg) #4

This is a 3DR u-blox GPS


(Erik Skovbjerg) #5

I got the type code here
u-blox 0 HW: 00040007 SW: 7.03 (45970


(WickedShell) #6

@ersko It sounds like this is fairly easy to reproduce, next time this happens could you set GPS_TYPE to 5 (which would be NMEA) and see if this then creates the GPS driver for you?


(Erik Skovbjerg) #7

This has been tried without and didn’t change any thing.


(Erik Skovbjerg) #8

Now the GPS_TYPE is set to 2 and it’s working fine in 3.4.6…


Dev Call Jul 10, 2017 2300 UTC
(WickedShell) #9

I don’t understand, tried without what?


(Erik Skovbjerg) #10

You ask me to try GPS_TYPE=5. This is tried on ver 3.5 and this didn’t help. When I set GPS_TYPE=2 this is working, but still stop working after some as noted above. GPS and cables are replaced, same problem.
When I installed ver 3.4.6, with GPS_TYPE=2 no problem and have now been running for hours, still fine GPS signal.


(rmackay9) #11

@ersko,

We’ve got some potential fixes ready for -rc11 and I’m wondering if you could give the changes a try before we push it out to everyone? The changes are that we’ve temporarily fixed a race condition in the SBF GPS driver and we’ve also re-enabled the NMEA GPS detection.

Below is a dropbox link to a zip file that contains two files. the -v2.px4 file is for a Pixhawk1, the -v3.px4 file is for a Cube (aka Pixhawk2).


(Erik Skovbjerg) #12

Hi

I will try to reload this within 1 hour…


(Erik Skovbjerg) #13

Hi
I have now loaded version 350rc11 as noted above and the problem is still the same. After 40 min GPS didn’t respond anymore. Waited i 30 min. still the same. Reloaded ver 3.4.6 and the GPS is back…


(Erik Skovbjerg) #14

Comment:
GPS_TYPE=2
This is screen copy when 3.5.0-rc11 was working


(Erik Skovbjerg) #15

Hi
I’m doing an other test on my HEXA, same hardware only diff number of motor, just to see if this also have problems. It can be small timing problems in hardware, but lets see what this test tell us. Pixhawk is loaded and calibrated and running, so now we just have to wait and see if this also fail. It’s now late in DK and I will continue tomorrow evening.


(rmackay9) #16

Erik
Thanks for testing. If you could send a dataflash log file (set LOG_DISARMED to 1 first) that would be good as well.
I guess this is the first time you’re using AC3.5? I.e. you haven’t tried any of the previous release candidates? Or put another way, what was the first AC3.5 release candidate that you’ve tried?


(Erik Skovbjerg) #17

Hi
Correct 3.5-rc9 was the first version I tested.
Under "Copter 3.5-rc9 spamming GCS with GPS 1: detected as SBF at ‘xx’ baud " there are a logfile from rc9 as requested. Later on today I will do a new test on RC11 with the LOG_DISAMED=1, if this from rc9 didn’t solve the problem. Logfile is “6 06-07-2017 22-25-12.zip”


(rmackay9) #18

Erik,

I’m unable to download that log that you posted in the other thread. It’s very possibly a problem with the discourse server used to host this wiki. In any case, can you post it again somewhere?

I can’t explain why the GPS was working for your vehicle with AC3.4.6 but not with AC3.5. There are many many users (hundreds?) who are using the same GPS without issue (including me) so it makes me think that it’s something specific to your board’s setup or configuration… this is why I’m keen to look at your logs to see if any of the parameters could be the cause.

If you’re up for it, you might want to try resetting your boards parameters. http://ardupilot.org/copter/docs/common-parameter-reset.html. You would need to re-do the vehicles calibration, etc afterwards though so I understand it would be a bit painful. By the way, it’s best not to save down parameters to a file and then reload them all back up again from that file because, like an overbooked airplane, it’s possible to fill the eeprom because we don’t actually have enough space to store a unique value for every parameter available. Instead, if you load parameters from a file, just pick the important ones (like the ATC* and WP*) parameters.


(Erik Skovbjerg) #19

Hi
There are two logs.

2017-07-12 17-56-49–normal.bin which is first start without problem.
10 12-07-2017 18-29-40-fail.bin which is after 30 min with startup fail.

10 12-07-2017 18-29-40 - fail.bin (1.8 MB)
2017-07-12 17-56-49-normal.bin (926.3 KB)

Note: As long the Pixhawk is running GPS is working, but efter restart of Pixhawk after some time it fail’s


(Erik Skovbjerg) #20

After many test I found the reason to the problem. The problem was a hardware problem in the Pixhawk. Pixhawn was replaced and now everything is working normal.
Thx for all the tries and help.

Regards Erik