GPS settings cleared

I’ve been playing w/ master and @andyp1per’s ‘small copter’ branch, and have noticed something strange.
On the two copters I’ve been using for that, I have not gotten any satellites recently. I’ve been trying every day for about a week.
Today I hooked them up to UCenter, and the GPS on each of those copters has no configuration.
I plugged in an identical GPS from a copter w/ 4.0.3, and it has a configuration in Ucenter.
I plugged one of the non working GPS’s in to the 4.0.3 copter, and it received satellites. I plugged it in to UCenter, and it has a configuration now. I plugged it back in to the original copter w/ master, and it kept working. So, the issue doesn’t happen all the time, I guess.
Copters on master and 4.0.3 have identical GPS configurations in their settings.

Does this make sense for any reason? I’m sure it’s not placebo or coincidence. Both GPS’s have not worked for at least a week. Both definitely had no configuration in Ucenter. I left one plugged in for over an hour, and it never received any satellites. Then when I plugged that same GPS into 4.0.3 copter, I had 3d lock in 5 minutes…

It’s this GPS:

-after working with it more, maybe the reason these had ‘no configuration’ is because the baud was wrong in Ucenter. It looks like the new arducopter firmware is setting the baud to 230400 and saving it to the GPS, while 4.0.3 is not. I didn’t try anything over 115200 in ucenter…
Still, they were not receiving any satellites for some reason… When I didn’t think they had a configuration stored, I assumed they basically had all the constellations disabled, so weren’t trying to receive anything. Now I’m less sure, but suppose that is still possible. They’re both working perfectly now after plugging them into the 4.0.3 copter.

No idea, but @WickedShell might have some thoughts

I’m facing the same problem too. I got 4 same Pixhawk4 mini with V4.0.4 Copters and 3 of them work fine with gps 3D lock. All of them are in same setting, but 1 can’t receive any satellite. Then I change the not working gps to a Pixhawk 4 with V4.0.3 Copter and it works well again.

I had GPS calibration disabled on the copters which were doing this.
When I re-enabled the auto-calibration on boot, they worked again. SO, maybe an issue w/ the GPS’s losing their saved config.