GPS not working at all in 3.2 APM 2.6

Hi all,

Been happily and successfully flying my old quad on version 3.1.1 AC 3.15.
Been a while since I updated firmware and Mission Planner, so I did just that.
However, since installing 3.2 - I get zero GPS functionality!
The blue lamp on the APM 2.6 only flashes briefly on power up, then nothing…

When I look in Mission Planner - I get zero satellites, and GPS HDOP also is 0.00.
No matter how long I wait this remains the case.
I reloaded 3.1.5 and immediately got 11 sats… blue lamp did the business… back to normal.
Can anyone please shed some light on this?
I noted ‘Dropped support for NMEA and SIRF GPS on APM boards’ in the release notes…
does that mean my kit is now too out of date?
For info, my external GPS unit plugs in the old style ‘side’ port on the APM, NOT the new top one

Best regards,

What is your GPS_TYPE parameter set to?
The parameter value should be 1 if you are using a uBlox LEA6 GPS.


Many thanks for the reply!

I eventually found the GPS_TYPE parameter in V3.2… (thank goodness for the ‘find’ button)
It does not seem to be a 1/0 setting, but rather a list of options from ‘auto’ to 'swiftnav’
It was set to ‘Auto’ - I changed it to Ublox and wrote the parameters.
Unfortunately still the same! no GPS :frowning:

Any further ideas?


The only thing that I can think of is to use the uBlox U-Center application to try and talk (38,400 baud) to your GPS to see what is going on with the connection issue.
To get the GPS to talk to the U-Center application will require a FTDI cable and an adapter cable to connect the GPS to the FTDI cable.
The older 3DR GPS were programmed for NMEA while the newer modules using binary. Your GPS may be programmed for NMEA and you need U-Center to load in the latest 3DR GPS configuration

Ok… thanks for that info…!
will give it a go, or maybe just buy a new GPS/compass unit?


I borrowed a brand new official 3dr compass/gps unit to test if the issue was with my old one.
I uploaded the v3.2 firmware - still no GPS :frowning:

As before, the blue lamp on the APM flashes briefly upon powerup, but then goes off and stays off.
…On the GPS/compass unit itself, I have a solid red led + a flashing blue led.
Mission Planner still has 0.00 HDOP and no satellites .

Can anyone please advise?


When your tried the other gps did you also use the cable that came with the other gps. Your cable might be bad.

Thanks for the replies…!
I’m an idiot… :blush:

When I tested the new GPS/Compass unit, I forgot to change GPS_TYPE parameter to ‘UBLOX’ (as mentioned by TCIII GM)
When set correctly, the GPS worked beautifully on v3.2!

Thanks for the assistance! - the borrowed GPS unit is now purchased for a good price… problem solved :smiley: