Servers by jDrones

GPS no fix problem


(akhil verma) #21

Hlo in ardupilot there is an anonymous error has come which shows the error of alt: check mag field . I don’t know how to tackle this .pls tell me the solution of this and one thing more even I have calibrated my compass so many time but still it shows bad compass health why?
Pls reply


(Sohaib Ahmed Jalali) #22

Hi,
Bad Compass health can be due to a number of reasons. Try calibrating the compasses separately of you are using more than one. Also run the “Compass/Motor Calibration” test in Mission Planner under “Optional Hardware” in the “Initial Setup” tab. The high current flowing from the battery to the ESCs tend to cause some interference in the compass. Anything above 25% is very bad. Interference below 15% is acceptable. To reduce interference try twisting the DC wires of the ESCs and the battery. Also increase the height of the compass. You can also try to place aluminum foil between the power distribution board and compass. Just be careful not to let the foil touch the power lines.


(Staelens peter) #23

I have another issue with my GPS. The strange thing is that the blue led is flashing on the 3DR module and that I have no problem with Qground control. However in mission planner all goes wrong. Has someone an idea?

. The first picture is when I start the motor test in mission planner. The second are my settings for the GPS. Last is my no GPS. However my drone is visible and it rotates with the turn of my hexadrone. I have this issue on 2 laptops and 1 desktop. Again on Qground control all works fine. I miss the globe and the map in missionplanner.