GPS_GLITCH all the time EKF Vairance

I’m running a pixhawk 1mb on my copter witch i use for some areal photography.

i have now started to get GPS_GLITCH messages on almost every flight.
i also get ekf variance message some times. and other EKF related messages.

I have tried to figure this out for a while now and this is my last resort.
I even tried dual gps setup and got the same kind of errors.
The copter flies good in stab and alt hold but complains about gps glitch and ekf variance in loiter and auto. i suspect that there is some other reason than pour gps since i have tested multiple gps receivers and the gps is mounted on a pedestal approx. 11 cm above the frame

Can someone please take a look at my log files. I can not figure this out.
Log shared on onedrive at!AmiOAvwbn4gdkPwBlbnot9PSlMzgEg?e=JkYmBe

Log Analyzer output
Size (kb) 16209.630859375
No of lines 190198
Duration 0:09:20
Vehicletype ArduCopter
Firmware Version V4.0.7
Firmware Hash 0bb18a15
Hardware Type
Free Mem 0
Skipped Lines 0
Test: Autotune = UNKNOWN - No ATUN log data
Test: Brownout = GOOD -
Test: Compass = GOOD - mag_field interference within limits (20.70%)

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = FAIL - ERR found: GPS_GLITCH
Test: GPS = UNKNOWN - join() takes exactly one argument (2 given)
Test: IMU Mismatch = GOOD - (Mismatch: 0.70, WARN: 0.75, FAIL: 1.50)
Test: Motor Balance = GOOD - Motor channel averages = [1504, 1492, 1482, 1482]
Average motor output = 1490
Difference between min and max motor averages = 22
Test: NaNs = FAIL - Found NaN in CTUN.TAlt
Found NaN in CTUN.DSAlt

Test: OpticalFlow = FAIL - FAIL: no optical flow data

Test: Parameters = FAIL - ‘MAG_ENABLE’ not found
Test: PM = GOOD -
Test: Pitch/Roll = GOOD -
Test: Thrust = GOOD -
Test: VCC = UNKNOWN - No CURR log data

Don’t know if poor reception is the problem but 10 sats, going down to 7 at times is not a good number to fly with. Your hdop drops to 2 at one time.
EKF variance is caused, i think, by bad gps performance.
On a F9P we usually have 25-30 sats with 0,6 hdop.
Analyzer is pretty useless, don’t know why it is still there.


1 Like

I think i have been flying with 8-14 gps satelites for years and it has not caused this fault before.
Is newer versions of arducopter more sensitive? I have tried to enable glonass and galileo via u-center but i do not get any more sats after i enabled it.

So do you think a new gps should solve the issue?
Was there anything else out of the ordinary?

Don’t know if it’ll solve the issue, what i know is that your gps is not performing well.

Thanks for the quick reply. i know what you are saying :slight_smile: I’ll try to disable all other rf noise, video transmitter, radio link+++++ and do a test flight.

The weird thing for me is that this frame and setup has been flying great before and i used to trust it enough to send it out of range on mission, now i do not do that.

i was faced same problem on my racer
video tx was causing GPS glitch
you can test by touching GPS wires or moving your hand above GPS antenna and you will see GPS glitch message on ground station
try to install far from together and put vtx antenna horizontally

I got a hold of an old 3dr gps with compass and that solved the problem.