"Gps for yaw" requires correct GPSn_POS_X and GPSn_POS_Y parameters?

From last week, I had a test-flight using the “GPS for Yaw” feature of ArduCopter 4.1.3 Stable with dual f9p gps (from holybro with firmware upgrade and antennas installed with 34cm distance.).

But it doesn’t seem to work.

When i change the flight mode from AltHold to Loiter, the drone starts moving somewhere and hovering is not possible.

When using Compass (m8n with ist8310), the current angle of the drone direction on the log was around 144 degrees, but the angle using f9p Gps for yaw is around 52 degrees. Could this be the beginning of something wrong?

I think my parameters are set well, but I don’t know where the problem is.
Waiting for a suggestion, thanks.

f9p_dual_gps_for_yaw.zip (814.9 KB)

Either your compass or your GPS orientation is mis-configured by 90°. It’s working, you just have a parameter wrong. Without knowing the actual heading of the vehicle during the test, we can’t tell you which is incorrect.

1 Like

When using Gps_for_yaw Feature,
I didn’t care about Orientation, because I think this feature didn’t use Compass.

Also, there doesn’t seem to be a parameter for the orientation of GPS? Where should I change?

Change the axis of your GPS_POS* parameters, assuming that the compass heading was correct.

1 Like

It seems that there is only a setting value for position, and no value for orientation?

You have the antenna positions defined on the X axis. If they are off by 90 degrees, put them on the Y axis, instead. Like this:

GPS_POS1_X = 0
GPS_POS1_Y= -0.17
GPS_POS2_X = 0
GPS_POS2_Y = 0.17

I’ll change the parameter in the daytime tomorrow and test it.
Thank you!!

1 Like

Sorry for the late test report. After changing the GPS_POS parameter as advised, it was confirmed that it works well. thank you.!