Governor Mode Tail Wag

Hello again,

I am hoping that I can find some help for a problem that I have been having for awhile.
When I first installed the APM on my TRex 450 I was running the ESC (Align 35X) in normal mode, not governor. I had the PIDs for yaw tuned for good tail control. This was with the 3.0.1 code. I am now running 3.1, with no change.

In pursuit of increased flight time and a constant rotor speed when climbing and descending, I switched the ESC to governor mode. Ever since the switch, I am unable to get rid of a constant tail wag (about 3-4" in amplitude at the tail rotor). My current settings are:

Stab Yaw P: 3
Rate Yaw P: 0.1
Rate Yaw I: 0.15
Rate Yaw D: 0
Rate Yaw IMAX: 20

It seems to be more pronounced at lower rotor speeds but can I not totally eliminate it with governor mode enabled. I can lower the rate P and the oscillation amplitude becomes more like 1-2" at the tail rotor, but then I have poor tail holding. I have played with different values of I and D as well, with no luck.

As I understand it, the throttle output from the APM to the ESC is fixed when in RSC mode and should not be affected by PIDs. Is this correct? (Was wondering if what I’m seeing is a motor torque induced yaw)

Has anyone else experienced this with an ESC in governor mode? Is running the governor at 51% throttle too low? Any other thoughts/fixes?


Edit: Rate Yaw FF: 0.04

This is a tricky problem because there are so many potential causes.

First, yes, I’d say that a throttle setting of 51% is probably two low. For two reasons:

First, most ESC’s cannot handle this and will overheat. I only recommend going lower than about 80% if you are using an ESC with Active Freewheeling such as the YGE series, or the YEP clones available from Hobby King. I’ve also seen an effect where it seems that at lower speeds, the ESC governor has a harder time controlling the rotor speed with collective changes, and can lead to torque problems.

The second thing, and this is complicated because it depends a lot on your setup, is that it can result in a loss of tail rotor effectiveness. When you lower the head speed, you need more collective pitch to remain airborne. This means actually the rotor is producing quite a bit more torque. But at the same time, as the tail rotor slows, you lose tail authority. So your torque demand goes up, while your anti-torque authority goes down.

Tail wag can also be caused by a number of other reasons such as slop in the rudder linkage, slow/weak servo, etc.

Now, with all that out of the way, there’s a few things you can do with the APM:

Yes, the throttle output to the ESC is fixed. It is not affected by the PIDS in any way.

Try playing with the H_Colyaw parameter. This is a collective-to-yaw-servo compensation. The parameters description is a little bit wrong. The range says I think 0-5, but in fact you might have a value between -10 to +10. So this can help.

But even more important than that, is the Rate Yaw FF number. You don’t show it, what do you have? This really settled down my tail in a hover. Be careful with the numbers, they are very small. IIRC, I have something like 0.005. Maybe it’s 0.05, I can’t remember the scale off hand. Start with 0.005. This value is only visible in the Full Parameter List.

Also, I’m a little concerned maybe your Imax is too low. There’s a weird scale factor change here. I normally run a number like 4500, but I think where you’re looking at it might be divided by 100, so 20=2000… but I’m not sure. What is it in the Full Parameters List? Set it to 4500 in the full list.

Then consider increasing the Yaw I-term. 0.15 may be too low. Slowly experiment with increasing it up to 1.0.

Rob, thanks again for your expertise. My Rate Yaw FF is 0.04.

I forgot to mention the make/model ESC in my OP. It’s an Align BL35X. The motor is the Align 430XL 3700kV. Both came with the kit. I believe I am running an 11T pinion, so it might be time to get a motor with a lower kV to get the head speed down with the throttle >80%.

I did some more research on the issue last night and it seems like the Align ESCs just have crappy governors and can cause the issue. Last time I flew, I turned the RSC setpoint to 80% and still got the wag.

Yesterday I experimented with increasing the Rate Yaw I to 0.5 and it made no difference. An my IMAX in the full parameter list is 2000.

I’m not having any problems with LTE. I have tail authority in both directions from my radio. The tail on this thing has been stretched to 480 size with longer blade grips.

I think it’s just the nature of the Align ESCs because it started right after I enabled governor mode. I think I will start looking at other ESC/motor options for my setup. I am shooting for some longer endurance on 350mm asymmetrical SpinBlades turning at about 2k RPM. Do you have any motor/ESC recommendations?

Thank you,

I’ve had pretty good luck with the Hobbywind Platinum Pro 40A ESC branded as K-force from Hobby King. Also the YEP from HK which is a clone of the YGE. And then I also have a real YGE on my Protos which is working fine. And in the past I’ve used the SuperBrain from HK.

So it sounds like everything is good other than the Align. :wink:

Does it have any parameters you can adjust? The YEP/YGE actually allow you to adjust the PID in the governor function.

I would like to get an internal governor function working in Arducopter at some point. Collective pre-comp is a good thing.

And for motors, I’ve liked the Turnigy SK3 motors. I’ve got them on my 450 and 600. Seem decent for the price. But I don’t have a lot of hours on them yet, so we’ll see.

Rob, thanks for the ESC/motor recommendations. I will definitely check those out. The only setting that the Align ESC has is throttle response (low, med, high). It seems to make no difference which one I set.

An internal governor in Arducopter would be awesome! Could the APM do it, or do we not have enough CPU?

I think the APM could do it provided the actual measurement is being done externally. I’ve already got a program setup to run on an Arduino Pro Mini. Just need the I2C interface to the APM. Just hasn’t got to the front of my todo list yet.

That’s good news. I’d be happy to help you test it!