Got rc in chanel values while using sbus RC in

I’m using pixhawk with futaba R6208SB receiver. when I tried to do rc calibration in qgroundcontrol, pixhawk found #1 chanel for all the controls. that is, qgroundcontrol promot “found chanel #1 for pitch” /“found chanel #1 for yaw” /“found chanel #1 for aeliron” /“found chanel #1 for throttle” without promotion to move the corresonding axis on transmitter. And In plot view , as shown in the attachment, the chan_raws keep oscillationg even when the stick is still. strangely the “mean value” does change according to stick movement and seems to be the right value. Also, the limit values of each chanel are correctly found during calibration.
And in mission planner, the values of rc in chanels are 65535 for most of the time, but it kept “blink” to correct pwm values and then back to 65535.

I uploaded firmware several times, but the rc in is still incorrect.

my setup is as follows,
transmitter Futaba T10CG
receiver futaba R6208SB
pixHawk 2.4+

the pixHawk is connected to a WIN7 laptop with usb cable. The safety switch is conneted too. beeper is not connected because I broke the connector off from the board when trying to disconnect the beeper in the wrong way.

got corrcet rc in values with ardu copter firmware.
But still no luck with px4 firmware.

Sent from my iPad using Tapatalk … _RC_inputs

Note: Futaba S.BUS2 receivers are not yet supported. These S.BUS receivers have been tested and are known to work: R2008SB, R6008SB.

You need to update your version of qgroundcontrol to get your R2008SB to work with the PX4 code.