Gimbal help v3.5rc1

I have a Quad with a Pixhawk and Taranis. and a servo gimble for the Lidar Lite. Since I downloaded V.3.5rc1 the Tilt(Pitch) .gimbal is reversed. In the Mission Planer gimbal setup page the does not let you reverse it. Also it looks like that page does not control the setup any more.
Any help please


Has nobody tested the gimbal setup in V3.5rc1. I(t worked OK in v3.4, so what has happened?

Hello I´m new in this forum - try to give some help for you. In 3.5 RC-out becomes servo. You have to use full parameter list to config the output. Recent MP can´t handle those new parameters. Have a look to

greetings from Germany

Thanks Roland, I found the info very handy, BUT it still will not reverse the servo
I’ve enclosed a screen snap of servo9 setup. I’ve tried putting 0 or 1 into the reverse param. Then rebooting the Pixhawk still thr servo does not reverse. Have you tried this yourself?

Geoff UK

I also tried to reverse one output with -1,0,1 Nothilfe changed. Somewhere in dev-talk it’s written the reverse value will bekomme something like “reverse” can’t remember exactly
I programmed the servo :slight_smile:

a hint for gimbal users which has enabled mnt_stab_roll
please test it on your configuration if this also occur

I still have problems with the Tilt,(Pitch) reverse, Have checked MNT_STAB_TILT, no change.
Im running A Pixhawk 2.4.8, No problem with setting up the compass (MAGs) I have not flown with 2.5rc1
due to my gimbal not reversing, also the weather is not good. Did you try with the manual calib.

Temporary i gave up to reverse Servo. do you have programmable servo? What kind of gimbal you use?
I have tried manual and on board mag calibration. If I enable mnt _stab the board refuse working when it’s tilt too much. If TX off also no problems.

The gimbal is made up using 2 servo’s, Not programmable, controlling my Lidar-Lite lazer height sensor If I go back to v3.4.4 all works fine. So it is a fault with V3.5rc1. setup, but I can’t get any of the developers to take notice.
Sorry can’t help with your AUAV board.