Servers by jDrones

Getting the Tarot T4-3D to work with the PWM servo output of the Pixhawk


(rrr6399) #1

Has anybody managed to get the Tarot T4-3D to work on the Pixhawk using PWM output from RC9 (Aux 1) and RC10 (Aux 2)?

It seems like most people have switched to using SBUS, but I’d like to use PWM if possible to control it programatically from the Pixhawk.


(Fred Robinson) #2

here’s the instructions for the Tarot T-2D but it is similar to the T4
http://ardupilot.org/copter/docs/common-tarot-gimbal.html#common-tarot-gimbal


(rrr6399) #3

@Helmet Have you had success controlling the T4-3D with the PWM output of the Pixhawk? I am wondering if it only understands SBUS.


(Fred Robinson) #4

Are you using a pixhawk or the Cube? The only board I am familiar with is the Pixhawk 2.1 and it will do either PWM or SBUS


(rrr6399) #5

I have both. I’ve been testing with the Pixhawk. I verified that the average voltage is changing on the servo pins 9 and 10 when I change the PWM from 1100 to 1900 but the gimbal doesn’t respond. Some people have claimed it worked with PWM and many others switched to using SBUS using the RC controller that supports SBUS. I didn’t see a way to programatically specify an SBUS channel and value compared to the PWM values for a given servo channel. I configured the gimbal for “Convention” receiver type right now compared to SBUS.


(Fred Robinson) #6

You have to specify Servo in MP’s camera gimbal setup page to use PWM. I connected my Tarot 5D3 through the pixhawk cube AUX channels using PWM and can verify that it does work.
For T4-3D:
-set gimbal to pwm (not to sbus)
-connect pwm1 from gimbal to rc9(pixhawk) AUX
-connect pwm2 from gimbal to rc10(pixhawk) AUX
-go to mission planner -> intial setup -> optional hardware -> camera gimbal
- set TILT to RC9 and do not check stabilization and then set what channel you want from radio RC6, RC7 …
- set PAN to RC10 and do not check stabilization and then set what channel do you want.
I Got these settings from here. https://diydrones.com/forum/topics/tarot-t4-3d-gimbal-compability-with-pixhawk?groupUrl=arducopterusergroup&groupId=705844%3AGroup%3A394475&id=705844%3ATopic%3A2190967&page=1#comments


(rrr6399) #7

Thanks for the response. I’m not using the RC to control the gimbal. I’m testing it by using the cmd_do_set_servo command to specify a PWM value for servos 9 and 10. This has worked with another gimbal that accepts PWM input.

I noticed here that the servo messages get broadcast to sbus as well as rcout:

I moved the signal wire to the sbus connector and reconfigured the gimbal to use sbus, but I got no response from the gimbal for that configuration either.

I’m beginning to wonder if there is a hardware problem with this gimbal. I noticed at one point that the cable connector was fairly warm. Its been cool since then so I wonder if something burned out.