Getting incorrect readings from Attopilot with Pixhawk

I wired up my attopilot according to the schematics on this site. I have tested all the connections and there is no short and they all have continuity.

When I view the current and voltage in the current and voltage sensor setup page the current always stays at 0 and the voltage is showing 1/10th of current.

I am using 3.1 and the newest stable mission planner. I have pixhawk selected for the hardware and Attopilot 180 selected for the current meter.

Ideas for what to try next?

So upon further testing I have discovered the following.

  1. The diagram on the arducopter support page for the attopilot is wrong, the signal wires are the reverse of what it shows.

  2. The Current that it measures is way wrong. Maybe 4x low? Havent put the props o it yet to see if it gets ore accurate at high currents.

Also there is no current in the heads up display. Not really a big deal I only need the voltage, but current would be nice as well…

The other day I installed an attopilot 180A sensor in my quad, I went to fly and the voltage was just reading 1/10th of what the current should be, that made me suspiscious so I tried some other wiring configurations and it turns out that the Current and Voltage in the instructions page are reversed.

On another note the current sensor is quite incorrect. I haven’t done enough testing to be sure, but I think it is about 6A low?

Hi kfennell,

You are right, the wiki is wrong, I asked the documentation team to fix it.

Regarding the current sensor accuracy, unfortunately I have no AttoPilot to test, if you buy from sparkfun maybe you can contact them to see if this is normal or is an isolated case.

Regarding no current display, did you select the option 4 on the monitor? this option is for voltage and current.

Thank you for your input.

Thanks for the help, just wanted to get it checked. I think that the attopilot is just off by 6 or so A so thats why it was showing 0 because I was only pulling a few. It worked when i just flew, but it was saying my 2900g quad was only using 12A

Thanks for the help

[quote=“RogelioN”]Hi kfennell,

You are right, the wiki is wrong, I asked the documentation team to fix it.

Is it correct now? It says to monitor voltage on pin 3 and current on pin 4. I’ve done that and in Mission Planner I set the pins in the Full Parameter List. I get the correct voltage but the current is listed as 284 which obviously is not correct.

BTW, the hover prompts and the info in Mission Planner for connecting the Pixhawk for voltage and current monitoring appear incorrect to me.

Any idea how I can get the correct current reading? Thanks.


No it is not fixed yet, this is the correct information:

V pin (voltage) to the Pixhawk’s 3rd pin from the left
I pin (current) to the Pixhawk’s 4th pin from the left

Hi Rogelio,
Would you please put in a link to the Wiki page that shows the incorrect information so I can fix it.
Thank You, :wink:

Hi Gary, … to_Pixhawk


Note: The text has been updated, the diagram will be updated soon.

Hi Rogelio,

Alex fixed the text and I Photoshopped the diagram. :wink:

Best Regards,


Thank you!

[quote=“gary”]Hi Rogelio,

Alex fixed the text and I Photoshopped the diagram. :wink:

Best Regards,


That diagram and the text are confusing. The Pixhawk is upside down so when you reference the pins from the left you are actually calling pin 1 on the board the last pin which is incorrect. Pin 1 is the first pin on the left when the Pixhawk is pointing up. I actually got the wiring wrong as I followed the text which says to put voltage on pin 3 so that’s what I did, as anyone who is used to referencing pin numbers would. Now that you have fixed the diagram I can see what I did wrong. It would be much clearer if you showed the Pixhawk pointing up and then fixed the text to reference the pins as number one from the left.