Servers by jDrones

FuriousFPV F35 Arduplane Nano Talon Setup

I’ve pretty much everything working on the board. All works fine, but the compass does not seem to want to calibrate. I can get the first progress line to go all the way to the end (id:0 99% or so forth). Then it keeps repeating the same thing over and over.
In the guide here.
https://ardupilot.org/plane/docs/common-furiousfpv-f35.html
It is told to disable it. Is this fine to disable compass and fly?
Thanks.

you need to post the tlog for us to know why it is failing

Thanks for getting back to me this fast.
How do I get this tlog? Let me google it and get back with this info.

(update: found this. Will get the info. https://ardupilot.org/copter/docs/common-downloading-and-analyzing-data-logs-in-mission-planner.html)

Thanks.

Here is the log.
2020-09-13 22-57-16.tlog (803.7 KB)

the problem is you have extreme compass offsets.


the normal earths magnetic field is about 300 to 500 mGauss. Your compass is reading a total field strength of over 6000, which means the earth field is totally swamped.
Can you show a photo of how you have the board fitted? Maybe you have a strong magnet near the compass?
I also fly a Nano Talon and the mag fields I have are quite normal.

Would this be caused by doing the board orientation offset? I have a 270degree offset which I changed in the parameter.

no, but that gray square in the picture looks suspiciously like a magnet. My nano talon doesn’t have a magnet there.

1 Like

Ah. You’re right. It is a magnet. Was there from the factory. Will remove that and see what happens. Thanks!!

also check if there is a corresponding magnet in the hatch

It’s easy to find the magnet :wink:

1 Like

image

It calibrated after removing that piece and the piece on the mating piece.
Thanks

1 Like
Servers by jDrones