Full throttle all time during Flight

All time I fly my gasoline plane

The throttle in FBWA mode while plane fly cruise about = 30-60 %

but when switching to Auto all the time throttle 100%

why this happen ?

If you don’t have an airspeed sensor, check what is your TRIM_THROTTLE set to.

hi @Anto6ka I have Airspeed sensor and my trim_throttle = 40

If you have AS sensor installed then TRIM_ARSPD_CM is your parameter. Set it to desired cruise airspeed in CM/s, this should cure the symptom you’ve described.

I Have AS sensor and calibrated but it keep go more than the value of TRIM_ARSPD_CM

Check if it’s using throttle nudge. Might be nudging to arspd_fbw_max value. I guess some logs would be helpful.

1 Like

yep, a DF log is what is needed

@tridge @Anto6ka

I will try to get the log as soon as possible ,

another question the values of speed parameter apply to Ground speed or Airspeed data ? and why they are always different

arspd applies to airspeed. Airspeed defines the speed in relation to air mass, measured by AS sensor, ground speed defines speed in relation to the ground, calculated from GPS data. As air mass is almost all the time moving in relation to the ground, those 2 speeds almost never match.
Check the wiki for some extensive information on the matter. You can find a lot of useful information on proper TECS setup for a stable and safe performance there.

1 Like