FS_THR_VALUE questions

Arducopter v4.2.1 on an mRo R15 Pixracer board in an Align TRex 500 heli.

Following my recent issue concerning disarming during flight, I’ve configured the new v4.1.X H_COL_MAX and _MIN parameters, as instructed by Bill’s responses in my previous thread.

At the same time I’ve also set ARMING_CHECKS to “1” (i.e. ALL), but then I got the Prearm Check FS_THR_VALUES warning, and no green LED on the Pixracer. Following the wiki I changed the Failsafe PWM value from 975 to 965 so that it was at least 10 PWM below the Radio3 PWM value shown in the Setup>>Mandatory Hardware>>Failsafe menu, which was 982.

So my questions are:

  1. I have flown this heli successfully several times previously with the Radio3 PWM = 982 and FS_THR_VALUE = 975 (i.e. only 7 PWM difference), so why was I able to arm then but not now?

  2. The wiki says that FS_THR_VALUE should be “At least 10 PWM lower than your channel 3’s PWM value when the throttle stick is fully down and the transmitter is on”. But it also says it should be “At least 10 PWM higher than your Channel 3’s PWM value when the throttle stick is fully down and the transmitter is off”. How do I read that value?

In MP the Radio3 low value doesn’t change when I switch the transmitter off. My receiver is a FrSky X4RSB, and failsafe has been set, as I always do, for zero throttle with all other controls at neutral. I can configure it for zero pulse in failsafe mode – would this result in a change in Radio3 PWM value when the transmitter is switched off?

Look at the status tab in the data screen of mission planner. There is a listing of different signals the flight controller sends to mission planner. You want to look at ch3in. It will show you the pwm value the flight controller receives from the RC receiver. Look at what the value is when the transmitter is on and then off. It can show you if you have the failsafe for the receiver set up properly.

@abenn1 i think what I told you above will show the same info you are seeing in the failsafe menu in mission planner

So looking at the radio failsafe wiki page, you may need to follow the procedures in the video for no signal or no pulses method. Hopefully that helps. I don’t have experience with this method.

I will say that it is good that you set prearm checks to all because based on this error, it seems your radio failsafe was not set up correctly.

Thanks Bill, I’ll set my receiver failsafe to “no pulses” which, presumably, will give me a PWM value of 0.

@abenn1 Did that clear the prearm check warning?

I haven’t had time to change my receiver failsafe mode yet, but the prearm check warning cleared as soon as I made the FS_CHECK_VALUE at least 10 PWM lower than Channel 3’s PWM value. Previously it had been only 7 PWM lower.

That suggests to me that Arducopter is not checking that the FS_CHECK_VALUE is “At least 10 PWM higher than your Channel 3’s PWM value when the throttle stick is fully down and the transmitter is off ”. In fact, how will it know what the receiver’s failsafe output is? I didn’t see anything in the wiki about setting the receiver’s failsafe to ‘no pulse’, so I think it might be worth recommending that somewhere.

I’ll get back to you when I’ve changed the receiver failsafe, to confirm what Channel 3 number I see in MP.

I’ve set my receiver’s failsafe to ‘no pulse’, and when the transmitter is switched off the main MP Data window momentarily shows" NO RC Receiver" then shows “PreArm: Radio failsafe on”. When the transmitter is on, there’s no PreArm messages, so it looks like it’s okay.

But ch3in in the MP Status tab shows a value of 982 at zero throttle with the transmitter switched on or off. I had expected it to show 0 with the transmitter off – i.e. with the receiver giving no pulses.