Frsky pass though telemetry issues on ArduPlane?


I just upgraded my firmware to ArduPlane 4.0 and saw that the pass through telemetry which I use on Pixhawk1 / Frsky X8R / Craft & Theory combo stopped working.

After fiddling with things, it looks like there is an issue with the Power Module of the Pixhawk. If I pull it off and power the Pixhawk through the servo rail or with the usb port, then the telemetry data starts flowing though to my transmitter immediately . As soon as I connect the power module back, things freeze up and the transmitter warns that the telemetry signal was lost.

By the way, i tried things with a new power module and the issue persists. I also tried to use a different script from Craft & Theory and it is clear that there is just no data coming through…

I know that in the ArduPlane 4.0 firmware, there was a bug fix associated with the Frsky pass through telemetry, so may be, there is a change in the configuration / protocol? I will downgrade back to 3.8 firmware tomorrow to see if the issue is indeed firmware related…

Any insights would be helpful.


just to bring closure to this topic, my issue was with high voltage level on my passthrough telemetry circuitry. For some reason over time the circuitry stoped tolerating a voltage level above 5V. Thanks to Alex, leading Yaapu, I was able to resolve the issue by adding 2 diodes to the V++ line to reduce the input voltage to the circuitry.