Servers by jDrones

FrSky FPort support - testers wanted

I have tested it on Matek F765 with R9Slim+. RC is working fine but Telemetry is not working at all. Tried various settings but no luck. Telemetry works fine in INav with same wiring. Need help please.

1 Like

All,
I would want to contribute and test F.Port, but I can do only as a bench test / function test, not flying yet with my build.

I am on Pixhawk4 - Copter 4.0.1-rc3 - Frsky RXSR ACCESS/EU - Taranis X9dSE2019, Hexa-X based on DJI F550.
With a fully functional S.bus, and S.port and Frsky passtrough Telemetry fully functional on Serial-4 and Yaapu9 on my Taranis.

I can flash my RXSR to ACCESS F.port, and give it a try, but I am not familiar with the process how to get the specific compiled code into my build. Or is it already embedded in 4.0.1-rc3 - Pixhawk4 ?

tnx
John

It’s not in the betas yet, so to test you’ll need to use a dev firmware (aka “latest”). https://firmware.ardupilot.org/Copter/latest/Pixhawk4/arducopter.apj

Tnx James, crystal clear. Will give it a shot next weekend.
Grtz
John

Hi ,
could you fix the problem ? Because i have the same!

post a tlog or onboard log (*.bin file) and also tell us what uart pin you are connected on. I’ll check your parameters

I have it fixed the Telemetry.

R9 Slim +
R9M 2019
X9D +
F765 Wing
AP 4.1.0

BRD_ALT_CONFIG,1
SERIAL7_BAUD,115
SERIAL7_OPTIONS,7
SERIAL7_PROTOCOL,23
RC_OPTIONS,0
RSSI_TYPE=3

And der F-port to TX6-Pin

Can confirm the same thing - 765 wing.

RC_OPTIONS,8 - No telemetry, only control
RC_OPTION,0 - Its all working… very cool :slight_smile:

I can confirm the following working (RC and Telemetry using Yaapu9 Lua on Taranis) :

Pixhawk4 + Frsky RXSR (ACCESS - F.port firmware)
The RXSR is straight wired from S.port pin to Tx on Serial4 (no juggling around with non-inversion pins on receiver). SerialX_OPTIONS=7 does the trick here.

RC_OPTIONS 8
RSSI_TYPE 3
SERIAL4_OPTIONS 7
SERIAL4_PROTOCOL 23

I still have the problem that Telemetry does not recover after RSSI reaching low value (not determined the threshold yet). When signal strength recovered, only the receiver based telemetry (RSSI and RxBT) are coming back up. This was also the case in S.Bus + Frsky passtrhough, not related to this F.port implementation.

Let’s have it ! One wire less !

grtz
John

So does the fport work on pixhawk? I do not, I am very surprised at who works, share details

Hi Ilya,
Details of my setup provided in my post. Pixhawk4.
Let me know what more dtails you´d like.
br
John

It does not work for me. I connected the wire from Sport to serial 4. Plus and minus set the settings. Is this enough?

no control no telemetry.
I checked betaflight everything works.

Hi Ilya,
I do not know about the R9 and the inverted/non inverted of the Fport. Your wiring seems ok.

My RXSR: flashed with ACCESS Fport firmware. Pixhawk4 with Arducopter 4.0.2.
S.port now being F.port connected straight to Tx on the UART. Settings of the several parameters as in my earlier post. Where Serialx Options set to 7 does the trick of making it a half duplex line, and the right signal inversions. Just plugged it all in, and have full telemetry and RC control.

Yes, I tried it. But it doesn’t work. i tried telemetry 2. on no

Hi Ilya,
you wire fport in 2 ways:

  • RC control only (no telemetry) by using the RCIN port, this is a “softserial” so no adapters required
  • RC + telemetry by using a serial port, in this configuration you need and inverter/ttl adapter such as this one

how to do this? what settings? how to connect to r9mm?


management works if you connect sbas to rcin, but it looks like it is not fport

earned !!! it was necessary to update the firmware to the latest 403. but there is no telemetry! only management
set RC_OPTIONS to 0 and it worked !!!

Thanks a lot.

presuming you mean plane 4.0.3, then you are not using fport. Plane 4.0.3 does not have fport support. You are probably using SBUS.
To test fport you need to use a ‘latest’ (also known as ‘master’) firmware

Hey
Tested on Pixhawk 4mini and R9 Slim+. S.port from receiver connected directly to RC_IN (2pin) on FC.
ArduCopter V4.0.4-dev.

SERIAL4_PROTCOL=23
SERIAL4_OPTIONS=7
RC_OPTIONS=0
RSSI_TYPE=3

Work ok with telemetry. Sometimes when I do range check RSSI displayed in Mission Planer drop immediately but when set normal power back RSSI rise on MP after few seconds. When on Yaapu telemetry RSSI is 100 on MP is 39.
Piotr

Servers by jDrones