Servers by jDrones

FrSky FPort support - testers wanted

Any telemetry or dataflash logs available?

Can your reproduce on the bench?

Peter

as Peter says, we’d really like the logs

Yes, happens on the bench as well. I tried putting ferrite choke on the receiver wires, unplugged the GPS/compass, powered via USB or main battery, turned VTX off, even changed the receiver antenna, still reboots.

I’ve uploaded logs of a reboot during indoor hover, let me know if you need more logs.

1 Like

Great, thanks! We’re investigating here ATM.

Could we ask you to try disabling various bits and pieces to see if they
cause the problem to go away, please? Just to help us narrow down where
the problem might be.

So, for example

  • disable the OSD
  • disable battery monitoring

Poking me on skype (peterjdbarker) might help shorten the loop.

Peter

Hi Peter,

I’ve disabled OSD and it rebooted twice immediately. Will keep it running on the bench tomorrow to see how it behaves.

Also I’ve set up a brand new omnibus f4 pro FC with all default parameters except the SERIAL1 group and a new R9MM on the bench to be absolutely sure it’s not a hardware issue. So far it hasn’t rebooted yet. Also Tridge pm’d me regarding test firmware builds.

for those following along, @polarijet has tested several firmwares and has helped us to narrow down the issue a lot. I have now reproduced the issue locally using information from logs from @polarijet. I hope to get a fix soon.

We’ve now fixed the bug @polarijet found and merged the fix to master. The bug was most likely if you had SERIALn_OPTIONS setup to do half duplex without having any of the inversion options set. That is why it bit @polarijet, as he had a R9MM which is non-inverted FPort, so he had SERIALn_OPTIONS=4
I do recommend that anyone using FPort telemetry update anyway, as the bug could hit anyone using FPort telem, it was just the probability was much higher with the setup that @polarijet has

1 Like

HI all,
Currently setting up arducopter on OmnibusF4ProV3 board and got telemetry working okay with Yaapu script on my QX7 transmitter using R9MM Rx.

I am using “Inverted S port” pin on R9mm to connect Tx 1 on OmnibusF4ProV3 board.

My parameters are:
Code:
SERIAL1_BAUD 57
SERIAL1_OPTIONS 4
SERIAL1_PROTOCOL 10
and everything is working fine.

So now i would like to run F port.Does anyone know the parameter settings required to setup F port on a F4 board?I know i have to flash my R9mm Rx to F port firmware but looking for parameter settings and connection to the F4 board.Do we need to use any converter and should i use Tx or Rx of the F4 board?

Please suggest.Thanks.

Edit:Found these settings from the start and middle of the thread.Going to try these.
OmnibusF4Pro

Connect an external inverter to TELEM1 (USART1). Setup as follows:

SERIAL1_PROTOCOL=23
SERIAL1_OPTIONS=160 OR (7 or 4 if using “inverted s.port” pad on R9MM)
RSSI_TYPE=3

@mike_d

I tried F-port on omnibusF4ProV3 with R9mm but it didn’t work.I am running latest beta arducopter which i updated using mission planner to latest beta firmware.

How did you connect the Rx to the board?

Should i connect only Tx1 to ‘Inverted S port’ pad on R9MM?I tried with serial 1 protocol to 23 and serial options to 7 but didn’t work.No control and no telemetry.

Finally Success on OmnibusF4ProV3 with R9mm without any converter!!

First tested my receiver with betaflight and F port was working.I then re-flashed arducopter and reset all the parameters to default and then after changing parameters to:
SERIAL1_PROTOCOL = 23
SERIAL1_OPTIONS=7

and only one wire to Tx1 of the board to “inverted S port” pad of R9MM (powered R9mm from the same UART 1 connector)

everything started working.I don’t know why it wasn’t working before.Now will test fly soon.

Hi!
Does anybody know what chip is used in this converter?

no ICs here, plain discrete components like this

Please have a look again.

that is probably the two transistors from @yaapu 's schematic in a single package

yes, something like this
image

I see. Well, I was sure it’s better to use some kind of CMOS IC:

no that just gets rid of the resistors required in a discrete bi-directional inverter…which works perfectly

like this https://quadmeup.com/smartport-inverter-for-f4-flight-controllers/

As I can see in the comments it exactly is not working perfectly and needs modification. ) Which is not the case with dedicated inverters.
But thanks anyway for the link.

I find the fact that Half-Duplex requires connecting to the TX signal soooo confusing. No telemetry I just connect to the RX pin, with telemetry I connect to the TX pin. Is this a hardware limitation?

It is the default for half-duplex for STM32, but you can set the SWAP option in SERIALn_OPTIONS to tell the uart to swap TX and RX.

Servers by jDrones