Servers by jDrones

Frame freeze/grey Video streaming UDP QGC 4.0.5 Ardusub/BR

Hi!
Having problem with low latency mode combined with video recording in QGC.
Posted this in GIT also: https://github.com/mavlink/qgroundcontrol/issues/8631

Using video recording in QGC 4.0.5 version gives a lot of frozen frames with a grey image.
This occur on both livestream in QGC and recording. In recording there is no “grey frame effect” but frame freezes instead.
Processor load is general higher than earlier QGC 3.5.2, 30% without recording, 40-45 with recording.
Effect is intermittent, can run for minutes OK, followed by several in 30 seconds.
Always happens 6 seconds after starting recording.
When the effect occurs QGC processor load typically goes from 40 to 80%,
I thought new video processing should mean lower processor load, not higher.
Also new 64 bit QGC should be more efficient, not less?
Using internal Intel graphic card instead of Nvidia card gives same result, both in processor load and frozen frames. Maybe that could be a hint since using nVidia card in my mind should take load of processor?
Screenshot at BR: https://discuss.bluerobotics.com/t/video-freezing-and-grey-frames-in-qgc-4-0-5-when-recording/7423/2

Can I log or help to find solution in anyway?

Bo

Tested QGC 4.0.8, better but still frozen frames seldom.
Screenshot:

More fault tracking:

Disable the Intel onboard GPU did not work.
All graphics passes the onboard Intel, even if its processed by Nvidia GPU.
That is the normal case, even in high end laptops.
Checking gamers forums I’ve seen similar problems due to bugs in games related to handling of dual graphics.

Since this worked on QGC 3.x but not in the 64 bit QGC 4.x I guess there is an issue in graphics handling in new QGC…?

Servers by jDrones