Forward Obstacle Avoidance using LW20/C

I have LW20/C connected using IC2 as RNFND2 and want to use this for forward obstacle avoidance. Can this be done as I haven’t had any luck so far using the following settings
AVOID_ENABLE = 7
AVOID_MARGIN = 5
AVOID_BEHAVE = 1
AVOID_DIST_MAX = 8
AVOID_ANGLE_MAX = 1000
PRX_TYPE = 4

I’m not sure how MP knows that RNFND2 is to be used for obstacle avoidance. I tried setting RNGFND2_ORIENT = 0:Forward but then it wont work. It seems to only work when the RNGFND2_ORIENT = 25 or down.
I have a rangefinder on RNGFND1 for altitude sensing.

If anyone can help with this it would be appreciated!

I have got this working but the confusing bit is that in Mission Planner Quick View ‘Rangefinder2’ will only show a distance when RNGFND2_ORIENT = 25 or down.
Is it possible in future versions to have the Quick View show a Rangefinders distance in all orientations?

@Peterarnold,

MP has a proximity viewer that shows what you’re looking for I think.

By the way, I found MP’s proximity viewer is a bit fragile so I’ve raised this issue to hopefully have it improved.

Thanks but ask how I get the Advanced menu item showing?
This what I get.

image

I have set Planner - Layout to advanced but that didn’t work.

Is the proximity viewer the same as in the Advanced Tools Ctrl - F?
Thanks
Peter

@Peterarnold,

I think the advanced options may only be available on the latest beta MP. You can upgrade by going to the Help screen and then push the button on the bottom right.

The other way though is use the older version you’ve got and press Ctrl-F and then there should be a proximity button somewhere on the window that appears.

Thanks for your help and I can find the old version of Proximity Viewer.
Unfortunately I get an error when selecting 'Check for BETA Upgrades and get the following error messages.

image

I have tried this before with the same results.
Thanks
Peter

@Peterarnold,

At this point it becomes a MP issue and it’s out of my hands I’m afraid. From my own personal experience I’ve gotten around this problem by completely uninstalling MP and then re-installing it again from the .msi file.

1 Like

Thanks for your time on this and I will try a reinstall.
Cheers.
Peter

Reinstall worked.
Thanks

1 Like