Servers by jDrones

Flying Wing FBWA auto pitch correct inverted


(Steve Auch) #1

New to the Forum. Love your work.
Having trouble configuring a flying wing.
Inverting one elevon to get correct roll and pitch on manual control.
The pitch correction in FBWA is however now inverted. Is there a way to correct for this?
Could swap inversions of the elevon, and remap the controller, but I suspect this will invert left-right roll for the auto waypointing, and doesn’t seem right.
Feels like I’ve done something wrong.
thanks in advance.


(tridge) #2

the problem is almost certainly on the input side, most likely RC2_REVERSED parameter is wrong, it should probably be 1. So when you tested in MANUAL you were testing with reversed input on pitch.


(Steve Auch) #3

Thanks Tridge. That is exactly the parameter that I failed to find on my own, and is most certainly the problem. I can’t test it for a couple of days, but will post result here. Thanks for you help.


(Nathan E) #4

I believe the wiki is correct as to the process of setting up your elevons, and it has a section explaining how to confirm that your inputs are correct.


(Steve Auch) #5

Agreed, and I hang my head in shame for not following the instructions to the letter. I made the false assumption that I did not indeed require my RC2 inputs reversed.

Still having some issues. Can you please check that documentation http://ardupilot.org/plane/docs/guide-elevon-plane.html#guide-elevon-plane “Verify RC Inputs” is incorrect when it says: " Command a roll to the right from your transmitter and confirm that the the right elevon rises and the left elevon lowers. "


(Steve Auch) #6

Whoops. No, this is for input mode, not FBWA mode.