Fly a few meters

Hello everyone, i’m newbie on quadcopter and ardupilot… ardupilot its my first time fw for my diy hexacopter
I’m take off in poshold. is it normal for the drone to fly a few meters after stops providing input from the remote?
It’s like an overshoot, but it’s not an overshoot
Its like latency or delay. After stop providing input from rc the drone not stop immediately
I’ve only ever flown cheap toy drones before
Thanks :blush::pray:

There is something called inertia and it needs to be taken into account when trying to stop something but also the flight modes are built to not immediately slam on the brakes to slow down. there are differences in the way POSHold and Loiter slow themselves and how much they brake. here is a list of all the copter modes and some of their features

There is a parameter regarding loiter and gps guided modes. It’s like a delay from where you let go of the stick/center the stick to when the copter starts to counter the movement and stop.

I’ll try to find the parameter, hold on

That parameter is set to 2, (2 seconds) per default i think. Set it to 0 and test fly agin!

Have you done all the tuning? Post a .bin log file from a flight and if there’s an issue somebody here might be able to help you along.

1 Like

Yes, do as Allister says!

If you haven’t set the initial parameters, set your filters, and done initial tuning and fine tuning, loiter or other gps guided modes won’t work well regardless.

Did you solve the issue you had?
this is my log
and one more question. i have done auto tune without Setup>Mandatory Hardware> Intial parameter setup
if i do initial parameter setup Ins_gyro_filter set to 46, and when i do autotune a message appears " [failing to level, manual tune may be req". so i let it value 20 (default from ardupilot)

my setup :
f550 hexa frame
h743 wing fc
bn880 gps + compass
9x5 thin prop
2212 motor
7200mah lipo 3s1p

May I ask why you have chosen to not do these as they are required now and take very little time to do so. I suggest you do them. Have you calibrated your radio and calibrated the accelerometers? I had that happen and it was mainly due to radio not being calibrated correctly.

You can leave that at 20, but accept all the other parameters. A F550 won’t be too far off the defaults, so that initial tuning will only help.

Have you set up the filters yet? (I’m on an iPad right now so I can’t view the log)

i have done mandatory hardware setup except ins_gyro_filter, i leave that at 20

I haven’t set up filters yet I’m having difficulty following the tutorial in the documentation

will you guide me?

are you using bidirectional esc firmware to use telemetry for your filter if so set these parameters do a short hover in alt hold:

here are the ways you can use notch filters:

INS_HNTCH_MODE: Harmonic Notch Filter dynamic frequency tracking mode

Note: This parameter is for advanced users

Harmonic Notch Filter dynamic frequency tracking mode. Dynamic updates can be throttle, RPM sensor, ESC telemetry or dynamic FFT based. Throttle-based updates should only be used with multicopters.

Range Values
0 to 4 Value Meaning

0 Disabled
1 Throttle
2 RPM Sensor
3 ESC Telemetry
4 Dynamic FFT
5 Second RPM Sensor

Most people will be using 1, 3, 4. I am no expert but because you have a f7 you should be able to use dynamic fft but keep in mind that option 3 esc telem is almost always better.

i use 40A Opto ReadytoSky ESC

from what I can see those are not capable of esc blheli-s or 32 so you will have to use the throttle based notch filter

ok i will do filter set up

previous value of ATC_ACCEL_*** is from autotune
ins_gyro_filter I leave the default 20
do i have to change ATC_RAT__ to new value or i can leave that default value?

Accept all those values except the INS_GYRO_FILTER. Don’t worry about the previous auto-tune. Once you get the filter setup it’s better to start from scratch and work with new values.

Throttle based filtering will work just fine for this setup.

i don’t know where is hover_freq and hover_thrust

have you enabled the notch filter? By setting this param INS_HNTCH_ENABLE to 1?

yes. where i can find hover_freq and hover_thrust value? thanks…