Servers by jDrones

Flight mode setting with Tx 9x and Kakute F7

Hi, I’m trying to set up a Kakute F7 AIO using the Turnigy 9x (standard software) in combination with the Mission Planner.
As the Kakute 7 does not support PPM; I’m using the TGY IA6 Receiver. The S-Bus/i-Bus from the receiver is connected to the port Rx6 on the FC.
I’m now stuck with problem to set up the flight modes.I believe I configured the RC correctly. I followed the steps in Ardupilot manual in setting up the 3way flight position switch with the gear switch, to get 6 flight modes. When checking the switch settings in RC Calibration of the MP I can see the following:
When toggling the gear switch I change the values on Radio 5 (channel) from1093 to 1925.
On Radio 6 (channel) I can see 6 different positions in combination with the gear switch and flight mode switch on the RC (1165, 1297,1426,1553, 1686,1814).
As said in the manual those signals should be sent to channel 5 and not to channel 6. Using an APM with PPM Receiver would request to connect channel 6 of the receiver with channel five on the APM. However I do have PPM, Kakute F7 and therefore cannot change the physical connection.
I tried hardly to find some support on internet but couldn’t.
I tried to change the Flt-mode Channel in the Full Parameter list to 6, saved the params, refreshed the params, rebooted MP and the FC, however in the flight mode menu the curent PWM remains 5 and when toggling the gear switch it will change from flight mode 1 (1093) to flight mode 6 (1923), but no reaction on the 3 pos Flightmode switch. What am I doing wrong? I hope this is the right place to post my querry.Thanx in advance for yor kind guidance/help!
Andreas

You need to create a mix in your radio to combine the effect of the two switches. It sounds like your 3pos switch is not a part of the equation at the radio yet.

try this:

Dont mind that they are using an old APM2.5 in the video - the setup on the radio likely hasnt changed.

PS - theres a million videos on youtube i searched ‘arducopter turnigy 9x flight modes setup’

Hi Ekliptiko,

thank you for your fast response. Of course I have browsed the net and youtube before and have found all the videos. And I believe that my Radio setup is exactly as told in the referenced video. However the problem is that I can not root the output of the Receiver Channel 6 to the FC input channel 5 because I use a Kakute F7 and the Kakute does not allow to use PPM and PWM receivers (only SBUS, iBus, Spektrum and Crossfireare are working). So I use a SBUS/IBus Receiver. I can see in the RC calibration of Mission Planner that on Channel 6 I get all 6 Signal length when toggling the two switches. However the flight mode needs to get these signals on Channel 5.
The Mission Planner offers to change flight mode channel in “The Full Parameter List” however this does not help.
Kind regards,
Andreas

Strange.In order to duplicate your problem I tried to enable flight modes on chan 6 and chan 7 (with FLTMODE_CH) on my bench Pixhawk then configuring the transmitter switches for either of those channels. Even though chan 6 or7 PWM values are changing on the Radio Calibration screen the flight modes do not change. Tried with current Stable and V4.4.0-dev. I don’t have an explanation for this.

I had the same issue with a TH9X. You CANNOT USE CHANNEL 5. What you must do is use a PWM to PPM encoder and connect the receiver channel 6 output to the encoder channel 5 input.

did you try changing the flight mode channel in arducopter params? just force arducopter to look at ch 6 instead of ch 5…

http://ardupilot.org/copter/docs/parameters.html#fltmode-ch-flightmode-channel

edit: NVM, I see that @dkemxr already tried this and is running into issues

Can you assign the switch to a different channel? Forgive me, I am not familiar with the 9X.

Been there, done that…

The root of the problem is the switches in the stock 9x radios like the OPs Turnigy and my TH9x, are hardwired to their respective channels/functions by the firmware.

What this means is that using the Gear/Gyro switch you get 2 flight modes on Channel 5. To get more than 2 flight modes you must use 3 mixes with Channel 5 as the Master and Channel 6 as the slave.

Each mix has an uprate and a downrate that can be adjusted to provide a given PWM value. Channel 5 is used to toggle between these 2 rates. Which mix is active is controlled by the 3 position IdleUp/FMod switch.

Making this work with an old APM FC is a simple matter of connecting the receiver Channel 6 PWM output to the Channel 5 input on the APM.

To get this to work with a Pixhawk you must use a PWM to PPM encoder. You must connect the receiver Channel 6 output to the Channel 5 input on the encoder.

In both of these configurations Channel 5 from the receiver is not connected to anything.

This issue holds true for using either the stock TX module and stock receiver, as well as using a FrSky XJT TX module and an X series (X8R or X6R) receiver.

The only way to “fix” this is to use an RC radio that supports serial protocols like SBUS, DSM, or iBus and that allows you to assign any switch, slider, potentiometer, mix, or function to any channel.

FWIW, I used my TH9x to fly an APM quadcopter and 2 flybarless helis for quite a while, but when I moved up to a Pixhawk and built a hexacopter I realized that the TH9x just couldn’t cut the mustard.

As I was already invested in FrSky receivers I decided to get a Taranis for my multirotors and use the TH9x for my helis.

Thanks a lot guys for all the fruitful input!

Putting all together there seem to be the below solutios for me:

  1. Use a Pwm receiver together with a PWM to Sbus converter connect the channel 6 of the receiver out to the channel five of the converter in.
  2. Mod the Remote Control (if possible) to get the signals out on channel 5!
  3. Get a different FC that works with PWM and use a PWM receiver ( channel 6 to 5)
  4. Get a different Remote Control that allows to use channel 5 to get the flight modes, e.g. Taranis!

However isn’t there the possibility to change the source code of the Mission Planner so that you may use channel 6 instead of channel 5 for the flight modes?

I think I will start with the Converter!

Thanks and have great day!
Andreas

yes, but I think you already tried this with FLTMODE_CH? It looks like dkemxr tried as well and it didnt work for them on Stable nor 4.4.0-dev. This change would happen within the Arducopter code, not Mission Planner. Mission planner is really just a proxy for the arducopter code. The flight modes and switching flight modes occurs on the flight controller, not within Mission Planner.

Throw out #2 and #3.

#1 is just a work around/band aid.

#4 is your best option.

Relative to this issue, the ArduPilot firmware is fine. The problem is THE RADIO HAS A HARDWARE LIMITATION and you can’t code around it.

…if only the parameter designed to address this exact issue (FLIGHTMODE_CH) actually worked…

Yep. At least you could get 3 flight modes.

I just tired it with one of my aircraft that has a 2.4.6 running AC 3.6.11 . I can see the mode changes in Mission Planner > Config/Tuning > Flight Modes, but Pixhawk is not changing modes…

Just bringing this to the attention of @rmackay9 in case he hasn’t spotted it yet.
Not sure who implemented the code for the flight mode channel option…

1 Like

@xfacta, thanks for bringing this to my attention.

I tested this using both Copter-3.6.11 and Copter-4.0.0 (which should start beta testing soon) and the ability to move the flight mode to channel 6 seemed to work fine. So I set the FLTMODE_CH parameter to 6 and then I was able to change modes with my transmitter’s channel 6 tuning knob.

What didn’t work however was Mission Planner’s flight mode page. It continued to update the green highlighting using channel 5 instead of channel 6. I’ve raised an issue here in MP’s issues list.

By the way, personally I think it’s not a great idea to uses switch mixing in the transmitter to allow selecting from 6 flight modes. In my experience it’s confusing and in the heat of the moment when you’re trying to get back to a particular mode it’s easy to make mistakes. What works better is to setup auxiliary switches. We’ve got all the flight modes selectable from auxiliary switches.

Ah OK, I see that it’s working using QGC so it’s just a MP issue. Thanks for the clarification.

I’m not following the point about using Auxiliary switches rather than switch mixing for flight modes though. I mean I understand how to assign flight modes as RCx options but not all flight modes are present. At least what Mission planner shows as options.

Servers by jDrones