Flight mode problems


I have just setup my first pixhawk and so far are very pleased with the features etc.

I have run into my first problem. Initially when I set up the radio and calibrated etc I was able to change flight modes using a 3 position switch. The green bar indicating which mode it was in moved as you would expect and the flight mode changed on the pixhawk.

However it now seem to have stopped working, The radio is still outputting the same signal on ch5 and APM Planner shows the pixhawk recognising this and the green bar moves on the flight mode screen. However the flight mode does not change on the pixhawk.
I have tried reloading the firmware, resetting all settings etc but no luck.
I can change the flight mode manually through AMP Planner using
Info View - Actions tab.

Another interesting point is that it will be in Circle mode when pixhawk is powered up and the tx is not, as soon as the tx is turned on it will change flight mode to rtl.

Hopefully someone can point me in the right direction - this is all new to me so I bet im missing something obvious.



Hi ben,
I had the same problem and it’s because with a plane it looks at channel 8 by default to change the flight mode, if you go into the parameters list on mission planner, scroll down and find where it says flight mode channel or similar, it should say 8, change that to 5 and write the parameters and you should be good to go.

Hi Lee,

Thankyou for your reply

It solved the problem!

Thank you again