Flaps Don't Open

I have changed flap1 speed, flap1 Percent,Slewrate. I have set the servo outputs to Flap Auto but the UAV still wont’t open flaps. It only open during takeoffs.
Please help me, what should I do?

What are your values for FLAP_1_PERCNT, FLAP_2_PERCNT, FLAP_1_SPEED, FLAP_2_SPEED? Do you use the TAKEOFF mode?

Note that in Manual, Stabilize, or FBW-A modes, flaps work with a switch you assigned for flaps on your transmitter. In RTL, Guided, and Auto modes, the actual flight speed dictates if the flaps come down or not.

I only used FLAP_1_PERCNT ( %60) FLAP_1_SPEED (14) should I use FLAP_2_PERCNT and FLAP_2_SPEED as well?

It might help if you post a log from a flight, otherwise we’ll just have to keep asking questions. Like: what is the cruise speed of the plane? How fast are you flying approaches? How have you set up your flaps? (Rc, servo, etc)

Nil Hanım,

If you could post your param file along with the flight log, then we would have all the info needed to diagnose the problem. As a start, the param file along your plane’s flight specs like cruise, takeoff and stall speeds help.

Iyi günler

Thank you so much. I think this might help you understand my problem
sorti 8.param (15.4 KB)

Your FLAP2_SPEED better be non-zero as the documentation says that it disables the flaps otherwise.

You could set FLAP2_SPEED equal to FLAP1_SPEED as well as the percentages so that when you are under your chosen speed threshold (14m/s) then the flaps move to fully deployed position at the correct list of flight modes. However, if 14m/s is much lower than your expected cruise speed, then flaps will engage briefly at takeoff only (0 to 14m/s) because your flight speeds will always be above that.

Make sure you put reasonable speeds in your parameters (for instance your ARSPD_FBW_MIN is 5m/s, is that intentional?). If you airframe is not custom, you can just share its model and we can guess the right speed specs).

You have TKOFF_FLAP_PCNT set to 60, so that’s why you had flaps on auto-takeoff, but that will not come into effect during normal flight.

Likewise you could also set LAND_FLAP_PERCNT so you will have flap during the landing sequence (If you’re using that).

The FLAP1 and FLAP2 settings will only work during auto modes and FBWB. If you’re in FBWA you will need to use a switch. (You’ve set to RC6)

But the flap still doesn’t work in Auto modes