Fixing Bad Gyro Health

A recent resurgence of “Bad Gyro Health” messages began on our flight team. Here’s our fix:

  1. In Mission Planner, navigate to the Full Parameter List.
  2. Choose SCHED_LOOP_RATE.
    a. Verify it is set = 400
  3. Choose INS_USE 1, 2, 3
    a. Verify they are set to 1, 2, 3, respectively.
  4. Choose INS_ENABLE_MASK.
    a. Verify it is set = 7.
    b. Do not use 127 (All) setting.
  5. Write parameters.
  6. Refresh parameters. Reboot and test fly.

Amelia Fox and the Mississippi State University Fox Flyers/Eagle Aces AMA
G. Oakley, JB Whittenton, AB Gaudin, J. Patterson, J. Dew, C. Oglesby

2 Likes

The mentioned parameters are missing. So, what to do next?

What do you mean Missing? They are certainly there in current Stable. But in any case the 400 is default and the issue with the IMU mask is fixed. So, the default settings for these parameters is correct.

Please send a screenshot

Not sure why that’s necessary but here is one. Of course the other parameter is present also.

same. i don’t have ins_use3