First time setup mission planer \ no heartbeat no mav link

Hey guys I am really new and a true rookie
I’m having trouble setting up my APM 2.5.2 board. I downloaded the mission planer ,and the drivers.
I set the com port the way it is suppose too ass I read so far.
I connected the APM with a USB cable.
Opened the MP and installed the firmware for my qaudcopter. So far so good. The firmware installation worked great.
I started the wizard and everything worked untill the point the software wanted to connect to the mav link. It did not connect. I always get a timeout. It never connects. And I really don’t understand why.
I tried different USB cables different computers but always the same.
I had the APM board connected just with the USB no in or outputs no connection to the mav link.
Sorry if I sound pretty noobie
Is there anybody who can help me? I’m getting pretty upset since I’m trying to get it to work since three days and reading a bunch of forums.

Do you have the correct COM port set in Mission Planner?

Yes i do have the right Com Port. With my Computer it is Com Port 3.
The Baund Rate is set to 115K in the divice Manager and the MP

Hi TheColonel,

Please run the ins test in terminal and post your results, here is how to do it: … sp=sharing

If the test fails, it might be a voltage regulator issue, here is more info: … ed-problem

Thank you for the quick answer.
i will try it later today and will post the results. What do i need to look for in the Results?
If the test does not go as planned i guess i need to send the board back and get a new one right?
or are there other opions i could to my self to fix it?

If you get error during the test then we can think of a problem with the regulator or the board.

To apply for a replacement you need to send an email to with your order number.

If the voltage regulator is the problem, replacing it might fix the problem, you can see the information from the link I sent you previously.

So thats what i got out off the test.
hope you can read it?

what does it mean?

oh before i forget. That is what i get when trying to connect the MAV Link

The terminal is displaying 2 errors:

  1. No dataflas inserted, during the terminal initialization
  2. Failed to boot MPU6000 5 times, during the INS test.

Those errors indicates the main microcontroller is not able to communicate to the gyro neither the dataflash memory. The most probable is the 3.3V regulator is damaged.

So mission planner is not able to establish a connection.

Please send an email to with your order number.

Thank you. I did order the APM with a GPS kit of a different side. Shouldn’t done that tho ? :frowning:
Thank you for all your help. I’ll let you know when i got my new board in and that it works the way it was invented :smiley:

Got my new Board in testet it and the MavLink works like a charm… Thank you very much for your Help. Indeed it was the 3.3V regulator that was damaged