First Flight very terrifying

Hello everyone , I’m just a newbie at this so please bear with me. I built my first drone it’s 550mm Quadcopter V type ,on Arducopter 4.0.7 ,I’m using a Pixhawk 2.4.8 ,a TMotor 45A 4in1 ESC, four 1000 KV motors ,and 10 inch Props. So I’m running the ESC in PWM mode because when I try using the ESC via the Servo Ports BLHeli32 suite it connects to the ESC , but i get Unknown Protocol when I read the ESC in BLHeli suite. I tried my first flight and it started to take lift off straight up, it got to about 10 feet in the air when i tried to reduce the throttle to land it didn’t respond right away and sort just kept climbing slowly and i panicked and hit my motor emergency stop and landed kind of hard from 10 feet , luckly no damage. I’m wondering if anyone can have a look at my Bin log and give me some advice as to what went wrong.
here is the link Dropbox - 29 2021-09-10 6-46-16 PM.bin - Simplify your life

You had a battery failsafe, it switched to RTL and it was climbing to RTL_ALT when you panicked and hit the emergency stop. Had you taken no action it may have landed without issue. Or not, the battery was down to 9.8 V.

Thanks for checking it out Dave , I guess I forgot to charge the battery, oops !
Also did you notice anything not right in the Auto log analysis.

Yea. Looks like you are on mostly default parameters. Connect to Mission Planner and use the Alt>A plug-in to fix that. If you want to use Dshot protocol motors have to be on the AUX outputs on That flight controller. I think you need to read the Wiki to move forward.

Sorry Dave I forgot to mention that I did have ESC’s on the AUX outputs and had the settings set to allow BLHeli Passthrough to servo’s 9 to 12. BLHeli 32 suite connected to the ESC ok , I was able to Flash the ESC with the latest 32.8 firmware via BLHeli32 , it verified each ESC .But when I read the ESC with BLHeli32 , the Input Protocol says : Unknown Protocol, sometimes it would say Oneshot24 which doesn’t exist, only on ESC #1. Never on all of them. So since then I’ve been using the ESC in PWM only.

Just looking at the log you posted. What would be the point of changing them to the main outputs whether you use PWM or Dshot? Troubleshoot the problem.

Sorry Dave ,not sure what mean ?

Just that you should be able to get passthru and Dshot functioning but even if you want to run PWM you can do that from the AUX outputs. Just pointing out that if you had them on the AUX outputs no need to change them back to Main.

ok so that would be good because if I wanted test the Dshot all I would need to do is change the params. and nothing else. Ok thanks a lot

Yes,right. You should only have to change these:

And set a serial port to ESC Telemetry if you want that and have connected the port.