First flight and autotune - impressions and small issues


Yesterday i did my first flight with 3.4rc2. I took the opportunity also do run a full autotune session again and the values found seems more reasonable than with rc1:

Parameter 3.4rc2 3.4rc1
atc_accel_p_max 57413 86065
atc_accel_r_max 66472 90537
atc_accel_y_max 15200 6778
atc_ang_pit_p 11.22 18
atc_ang_rll_p 11.84 18
atc_ang_yaw_p 6 3.89
atc_rat_pit_p 0.63 0.23
atc_rat_pit_i 0.63 0.23
atc_rat_pit_d 0.0308 0.01999
atc_rat_rll_p 0.4587 0.222
atc_rat_rll_i 0.4587 0.222
atc_rat_rll_d 0.02173 0.0152
atc_rat_yaw_filt 1.792 1.073
atc_rat_yaw_i 0.1222 0.1240
atc_rat_yaw_p 1.222 1.240
atc_slew_yaw 6000 1000

It looks that atc_rat_yaw_p is very high, don’t know why or if it is normal. atc_ang_pit_p and atc_ang_rll_p have decreased from 18 to around 11 which is between standard boundaries.

Two issues that I’ve found:

1st. After arming px4, the escs are arming randomly, and it could take up to one minute to have all them ready to go. I’m running blheli 14.6 and haven’t touched neither my esc nor anything else related to HW since upgrading from rc1.

My mot_pwm_type is = 1 - I have tried to set it to 2 but with that I’m unable to calibrate. Tried that to see if it could fix or if it would work, but it didn’t.

2nd: I have had a hard time with altitude controller. After log analysis I think it could have been caused by some noise on my rangefinder and my settings for EK2_RNG_USE_HGT which was 50%. I will get it back to the default of -1 until I’m sure that the rangefinder is 100 reliable.

The funny thing with motor arming doesn’t happen with normal pwm output. I’m opting out of oneshot for a while…

So, with mot_pwm_type is = 1 you don’t have issues? I hope I have in 2 (oneshot 125) and, time to time, I have to wait all motors spin when armed or have to reset the FC, perhaps is usefull for devs if you can share a log.

1 Like

No, I dont have issues with mot_pwm_type =0. Summarizing :

mot_pwm_type=0 (pwm) - works OK
mot_pwm_type=1 (OneShot) - works with delay in RC2 and works OK in RC1
mot_pwm_type=2 (OneShot125) Doesn’t work in RC1/2

1 Like

Thank’s I’m going to test mine with type=0

Type=0 looks to solve my esc calibration issue, thank’s for share your results Fernando, I check flying as soon as I can

Fine ! wish you a good flight. Lookking forward to test my autotune results as well. Can`t fly because of the olympic games…

1 Like

One thing I’d like to mention is that -rc2 has a 2 second delay built into the arming. So the tone sounds, then two seconds later the motors start. There’s definitely an issue with the one-shot support that we are (or will) look into as well!


Thank you Randy,

Cloud you please give your word about my autotune results of roll/pitch p about .45/63 and yawp of 1.22? It is a 4Kg hexa with powerful motors ( hovers at 0.30 ), I was expecting something under these values.

Regarding the Altitude hold controller , I’ve find out that the cupid was the maxbotix sonar which was sometimes detecting my landing skid and oscilating from wherever the altitude was and 22cm.

That made ek2 go crazy. I believe this issue has started when I replaced my original skid for a tarot auto retract one. It does have some play on its legs so when it was in flight, the play triggers the false reading.

It wasn’t happening before ( RC1 ). Something should have changed in code that now it makes this kind of issue ( sonar noise ) really important. In the process of testing , before figuring out it, I went very very close to a big crash. Luckily my reflex were fine and I was able to switch to stabilize and give full throttle before the whole stuff smashes in the ground.

I have repositioned the rangefinder and the problem is gone, however I can still feel a hiccup when approaching to land from hight heights ( > 15m ). Maybe when sonar triggers in it may cause an abrupt transition on the matrix.