First Auto Mission - Some expert here, please?

Hi, I tried today an Auto mission for the first time. The “controller” was Mission Planner 2 on an Android Tablet. I attach screenshots of the mission, and you can see the resulting on-board video here:

The problem is: as soon as I start the mission (the IRIS was already flying) you can see that it points the gimbal down, while, in the mission, I have set up a ROI point in the middle of the field. Then the IRIS fly correctly through the waypoints; at the last waypoint it raise the Gimbal the turn it down again. During the major part of the mission it seems to point the gimbal in the right direction at least, while at the end it moves right without pointing at anything.

Someone has suggestion ?? The region of interest Waypoint was the number one of the mission. I set it at altitude 0, I wish to point at terrain level…
(waypoint 8 is RTL)

Please someone can help ??
Thank you

PS: another question, what does it mean when Altitude on waypoint is red ??

I believe the reason it’s pointing at the ground is because the Alt was set at zero. Try setting the Alt. 50% to 60% of your waypoint altitudes and you may have better results. The altitude set allows you to control the cameral angle.
Altitude red means your next waypoint is not matching the previous.

I have found that on some tablets Droid Planner 2 will take over the camera and point the camera in strange directions. Try fling the mission with Droid Planner disconnected before you plug the battery in.

You may want to switch to Tower as it seems to work a little better in that area.


In my experience, an altitude of 0 meters for the ROI should work fine on either Droidplanner 2 or Tower (aka Droidplanner 3).

I always have 1 waypoint before I set the ROI waypoint. That’s not a deliberate practice - its just sort of works out that way. I guess in my head when I plan missions, I always think in terms of “get to the starting point first, aim the camera at the ROI and go.” Thinking back, I can’t recall a single time that I have started a mission with an ROI waypoint. You may want to try the same to see if that helps with your issue.

The red tells you that there is an altitude change between waypoints.

I would definitely upgrade to Tower from Droidplanner 2.

On another note:
Once you get it working, you may actually find that you want to set the ROI altitude at around 10 meters or so. It just changes how your video will be framed. For a mission like the one you posted, I would probably do 10 meters to keep a little bit of the horizon and sky in the frame. I’m always playing around with the ROI altitude to get the perfect framing. In some cases I even set it negative.

Hi guys,

thank you, all your suggestions makes sense !

I will try them all, next weekend. Just another thing: Yes I have Tower installed on my tablet, but yesterday when I tried to use it, it did not download the “google map” for the area, while Droidplanner 2 had no problem, that’s why I used the latter

the tablet was connected to internet without problem, but I cannot get any map on Tower. I tried to click the “my position” icon, zoom in and out, move the map… nothing helped. Some clues ???

thank you !

Tower uses the same folders as Droid Planner so if you see the map in Droid Planner it will be there in Tower. Must be a setting. Some people have said that the use offline maps was backwards.

I always use offline maps as I don’t have internet access when I fly.