Firmware update: No response from board


Tried updating the firmware for the first time on a new Pixhawk following the steps

Got up to: Unplug board, Press “OK” Plug in board, then after some time where it says “Connecting” I get the error “No response from board”.

I tried the instructions on the bottom of the page of the link above - reinstall- but it didn’t work. Changing COM port numbers to prevent possible conflicts also didn’t work.

What do I do to fix?

When the MP says to unplug the Pixhawk, press OK, and then plug the board back into the USB connection, instead of unplugging the Pixhawk, get a very small screw driver and try pressing the Pixhawk FMU reset button, which is on the same side of the case as the USB connector, then press OK.

Hi guys, so did this work??

I had exactly the same problem, but pressing the reset button didn’t work for me…

I was able to load firmware when I switch to AP planner on my MAC, but the firmware caused the Artificail Horizon to roll uncontrollably…

So then I used my mates PC which had same problem until I read somewhere on DIYdrones to load aeroplane firmware, then back to copter, which worked… weird… :open_mouth: :open_mouth:



Thanks for the replies.

Tried Manual screwdriver reset.
Tried loading Plane and Quad first (Mine is Hexa).
Tried uploading manually with px4uploader.exe
Tried different MicroUSB cable
Tried different COM ports

Problem persists. What to do next?

Try another PC…

I read somewhere that some USB outputs are pushing it to provide the power req’d for the update…

(it doesn’t make sense I know) as your PC can still boot the Pixhawk, but I have to use my mates PC to do firmware upgrades, (even though my PC will run it fine once installed), or my MAC… but the MAC is scary

I’m thinking of getting some kind of powered USB hub to try…

major pain in ass!!


Thanks. Tried a laptop with the same result.

I could try up the USB output or one of those 2 into 1 USB cables for external hard drives.

Very frustrating. I migrated from ZeroUAV after useless tech support resulted in a very bad crash. Just rebuilt and now stuck at step 1 with the new setup!


Forgot to unplug the Sbus along with the other peripherals to save power. MP firmware upgrade didn’t work, but px4uploader did!

Little bit late to ask but not sure I have the latest version though. Where do I find the latest multicopter firmware to download and install?

Issue Solved.

I agree that it has to be the USB power output plus resetting the board with the screwdriver and not unplug-ok-plug in as instructed.

Got the firmware uploaded after a couple of tries with only the buzzer and switch connected.
Tried calibrating the accelerometer, compass and GPS but it all failed.

Switched to Lipo power and 3DR telemetry radios and everything worked fine.

Just have to go through the settings then I can finally get her in the air!

Thanks for your help : )