Firmware installation problem for APM 2.6

I’m doing a first time set up for my 3DR Quad using an APM 2.6. I’ve managed to install the Mission Planner software and the device drivers for the APM. I’ve set the baud rate to 115200 on both the Com port and in MP and selected the correct Com port in the MP dropdown menu (the MP dropdown doesn’t show the APM - only the port number?)
When trying to install the arducopter firmware, it goes through the process of connecting with the APM and then starts downloading the Hex file. I then get a “failed upload” prompt with an error message “Communication Error - no connection”.
I’ve noticed mention of insufficient USB voltage to power the APM in previous posts. I’ve measured the voltage across my APM power rails at 4.98V. Is this sufficient for the APM 2.6 or do I need to get a powered hub to up the voltage? Could this be causing the problem I’m having?
Also, what is the correct voltage required for the APM to perform as it should?


I have been using a powered USB hub to provide enough current to the APM and have not had a problem upload code or modifying parameters.
Your COM port should shown the processor type (ie 2560) next to the COM port number in the drop down menu.
TCIII Developer

Thx, I’ll try a powered hub and see if it helps.

Ok, so I went out and bought a powered USB hub and I still have exactly the same problem - I get a “failed upload” prompt with an error message “Communication Error - no connection”. Also, the processor type is still not showing up in the MP drop down.

Any ideas on where I go from here?

Your help would be much appreciated:)


Problem solved - Turned out to be a Windows 7-USB issue on my laptop. Still not sure what is causing the problem, but at least my copter is flying!