Firmware doesnt update fenceradius


Is there a upper limit in fenceradius?

I updated the value to 4000 m ( 300 default ). However, the drone constantly switched to RTL after reaching 300 in both AUTO and LOITER mode. I tried different values, both higher and lower, but same result.

After disable fence, it works thou.

Am i overseeing something, or is this a bug in 4.3.3?

Please share the logs from the UAV you can download and anonymize the log using Mission Planner.

Hi. Please see attached logfile. I changed the radius to 1500 meter this time ( was 10000 ), now it enters rtl after 250 meter in auto mode.

And, the fence was enabled again when i started the drone, despite i disabled it?

I have a theory. I checked the GCS ( UGcS ) and notised that the radius was set to 50000 meter.

Could it be that this overrides the autopilot setup, and because its out of range ( 10000 meter ) cause the behaivor?

I dont get any messages in the GCS, it just switches to RTL.

Doesnt it provide a message if it reaches fence?

RTL in that log is from a Radio Failsafe.

Then its even more strange. Its programmed to continue in automode, and i had a solid rc signal including video?

Is there some way to make it less sensitive? Why doesnt it continue in AUTO as its set to do?

Not with FS_OPTIONS set to 16 you don’t.

And you are posting in the wrong thread. You are using 4.3.3.

Ah, thanks. Its changed hiw to set up in 4.0.

Changed to correct thread.

Yes, carefully read thru the options as it has changed significantly.

Will do, and test it … thanks