Servers by jDrones

(FALSE) Low Battery Warning - Still have proper voltage

Your log indicates all mode changes were done with the RC transmitter.

I do change modes i.e., stabilize, lotter, P-Hold etc … during the flight to give me an average recording of what is not correct on my battery level … After today’s flight I still get a warning and the drone RTLs back home … After landing I check the battery condition … and in today’s case the battery level was 11.58vdc.

So why or what parm is giving me a false warning that my battery is depleted?

What’s your BATT_LOW_VOLT set to?
BAT_CRT_x is the second stage…it’ll warn you before it hits that.

http://ardupilot.org/copter/docs/failsafe-battery.html#failsafe-battery

BATT_LOW_VOLT = set at 8.7
BATT_CRT_MAH = set at 2500 mah
BATT_CRT_VOLT = set at 3.43 V

I believe I read the literature on fail safe battery settings … And thought I had what I needed for adjusting the parms of this drone … STILL SCRATCHING MY HEAD >> UHMmmmmm

I would hate to have to turn everything off and not have any failsafe…

I don’t know if its causing the issue but you have the fail safe strategy backwards as Jakob suggested… Low should be the 1st stage and critical the 2nd stage. Your critical capacity is 2500 mah and your low capacity is 1502. I suggest you disable all the critical parameters and simply set the low values. Try that as a baseline FS.

OK… I changed the settings:
BATT_LOW_VOLT to 0
BATT_LOW_MAH to 1200
BATT_CRT_MAH to 0
BATT_CRT_VOLT to 0

I really think the BATT LOW VOLTs must be a bit squirrely for the 10 sec time limiting …
Just out of curiosity what do you guys have yours set at?

Where are you seeing warnings for low battery show up? To the best of my knowledge there isn’t a MAVLink message that directly indicates a battery failsafe. A GCS can throw additional warnings for you, but if the failsafe isn’t triggering I’m confused what is giving you a warning.

As stated at the beginning …
My flight times are not normal and limited to about 3 mins … my battery warning is coming from the drone itself beeping letting me know batt is low and it RTLs to the landing area …

So as a result to my settings for the battery parm when it reaches its battery fail-safe causes it to RTL…
That’s what Dave and Jakob is informing me on my parms… had my parms settings off …

If weather permits today I’ll try another flight to see what my flight time is… Would be curious to see what others have for their setting for 11.1 batt.
BATT_LOW_VOLT
BATT_LOW_MAH
BATT_CRT_MAH
BATT_CRT_VOLT

Thanks for your response…

You need a low volt limit. I use these for a 4S 1800mah battery on a 210 quad that typically doesn’t get very far away. I don’t use critical FS as I mentioned. You certainly could if you like but get basic FS working 1st.

Batt%20FS

I checked my settings … Battery look similar to yours … yours being 4S-1800 while mine is 3S-6000
20% MAh is correct and thought stepping it up 100 mah … My voltage setting is kind of a guess … @ 20% voltage I averaged 8.88 and didnt want to go there …

image

I use 3.2V/cell typically unless it’s a longer range craft. Some will consider this too low. Or I don’t use a voltage limit at all and rely on mah. I have telemetry on the transmitter for all craft so monitor that primarily.

I have telemetry on my unit as well … and normally take my laptop out to the field to monitor … the weather has been off and on here and would rather not take a chance to ruin my laptop.

Waiting on my new radio to arrive … ordered FrSky 10X Express to replace my RadioLink AT10 where I’ll have voice.

Getting back to BATT_LOW_VOLT … I may re-adjust my setting from the 9.9 to 10.5 making it 3.5 volts per cell … this way it doesn’t get too low possibly ruin my battery …

However, want to thank you guys bring more light on battery set points in MP…

I’ll throw out another set of logs when I do the next flight …

Get Frsky telemetry pass through setup on your new Transmitter Doug! In many cases it serves well as a ground station.

Will do on the telemetry pass through … I hope it will be in by the end of the month… but really doubt it… The Express is supposed to be the newest radio by FrSky … so we shall see …

BTW: Took the drone out to fly … have not posted my logs yet … However, I used the last ran battery and figured if there would be any alarms it would sound of with a lower cap battery … Still tested out at 11.58v !!! … Ran the bird around for about a good 10 mins … buzzer never sounded off … So I have to say my previous settings were way off and now from the feedback “All Is Well” . When have a better day I’ll give it a really hard run …
When I finished my flight the battery still was looking good … it was approx 11.22 so it didn’t hardly eat up any electrons from the pack … Next time I’ll run my timer and get a better feel …

I hope others pickup on this …
As much of a pain it was for me flying and then 3 mins later the buzzer would go off and RTL back to the home base was really getting frustrating… yet the batt packs still had a lot of charge remaining… I could not see what in the world was going on …

Want to thank everyone for their support and feedback!!!

I have the exact same issue, short flight time 2:22, and the quad switches to LAND mode & lands. My Taranis captured lowest battery of 10.7 volts and max current of 23 amps. At landing the tm reports 11.9 volts. Battery & quad are news battery had 4 cycles.
Quad F450 Frame, Hobby Power 2212-KV920 motors, Pixhawk 2.4.8 with Ardupilot 3.6.9 firmware, battery OVONIC 3000 mAh 3S, 50C. As the TM reports low voltage could the problem be related to the power module?
I have validated the power module voltage reading from 9.6 to 12.6, it matches exact. Motors not running no current for this test.
New battery is in the works 4200 mAh 3s 35C. Should be ready in a day or 2, I will share results.

Thanks Dennis… Did a flight today… The first was in the morning where I was in the air for about 2 mins … and oops there goes the buzzer sounding off letting me know I had low battery not to mention it was in progress to RTL. My radio with telem showed over 11.volts so I knew there was a setting issue.
Here is my first report .

Bad%20Batt_

Went back into MP and did some minor adjustments … the bird flew a lot longer but still came on when the radio showed over 11.volts … there again my radio might not be accurate and didnt have my meter with me at the time to check what the battery voltage was …

Hi

Assuming that your battery monitor is correctly calibrated, I believe that your battery is either old and drops too much on the Voltage as soon as some load is applied (not enough C rating for the load), and also I would say that you should revise the motor/prop/battery, because at 3S 50A, the load on the battery might be too much. When you land the voltage goes up, and that is expected.

https://plot.dron.ee/zoVw

Thank you Luis …
Did you use my old log file? If you did, I may need to get you a more up to date log …

Still tweaking out some of the issues with the model … but the last flight I had lasted for a good 15 mins …

I also was doing auto-tune on last flight … Seems the drone flies great and is a little tweaky on the sticks but that can be adjusted.

Let me know if you want to look at another log …

Thanks again for your help … Still learning a lot about the programming and setups BUT … I’m getting there …

Please do.

I would suggest that you use our good friends at Drone.ee tool to check your log.

https://plot.dron.ee

If you want to share it, press upload at the top right corner to store the log at Ardupilot servers, and share the link here.

Excellent … Thanks Luis
Doug C.

Servers by jDrones