Failure to launch

I’ve recently experienced some odd takeoff behaviour with my Bixinator. I have everything setup for auto launch in my Mission, I arm the plane and throw it and some random (apparently) percentage of the time the motor doesn’t fire and it just glides to the ground. If I reset the mission and try again, it sometimes works. Or sometimes it works the first time. I haven’t been able to figure out what I’m doing wrong. This is one log that shows this, I gave up after one failed launch and just did an FBWA takeoff before switching to a auto. I’ll see if I can find some other examples.

This is a Bixler 2 with a PixRacer R15 running I think 4.1.5 or 4.1.6.

Dropbox link here Dropbox - 2021-12-31.BIN - Simplify your life

Only the beginning is relevant. At the end I suffered a mechanical failure that caused a rather spectacular tailspin and crash, but not part of the problem.

You could turn down your TKOFF_THR_MINACC.

Or what I do is set TKOFF_ACCEL_CNT to 2 or 3 and adjust the TKOFF_THR_SLEW to something that’s comfortable. This give me “shake-to-wake” so the prop is turning before I throw the plane, but it doesn’t go full beans right off the start so I have time to sort myself out or disable if I’m need.

I’ve set up pushers and tractors this way. And I can still count to 10. :slight_smile:

Here’s one where I had two flights on the same outing. The first failed to launch so I did an FBWA launch. The second auto takeoff failed so I went back to the bench and reset the mission again then tried again and the auto launch worked. Same day, same plane, same PixRacer, same thrower.

Tim, I hope you don’t mind the piggy-back on your post, but I have a similar issue. Matek F405-WING, 1880 Skywalker plane, Crossfire and FPV on it.

My autolaunch has worked for a long time and then stopped. I do not recall changing settings, and hardware did not change. I made a Crossfire firmware update only, not related to this I think. In an effort to fix the issue I have changed some settings, but I believe for the better after lots of reading and trials.

This is my first post here so I hope I get the log file upload right. .bin format. Link here, expires on 17 January 2022.

I have TAKEOFF as the first waypoint in planner. 15 degrees, 15 meter alt. (yes I know a bit low, but I have tried higher). I arm in MANUAL or AUTOTUNE, check that I have control of the prop, switch over to AUTO, half throttle. At this time the OSD shows Waypoint 1: TAKEOFF. It shows an acceleration value higher than my setting, and ditto with the ground speed as I walk fast with the plane and shake it to simulate a launch. I even reduced the TKOFF_THR_MINSPD to 3m/s and TKOFF_THR_MINACC to 7m/s/s for the last test.

Could it be that my ground speed is insufficient at the exact time I shake my plane? Unlikely but not impossible, since I walked with my plane for the test. (I threw it several times in the past and it failed). Am I even reaching the required ground speed?

Thanks all. Sorry for the long story, but I hope to get all the clues down on here.


1 Like

Thanks Willem - that’s why I created this topic - so others could join. Your experience is similar to mine except that for me sometimes it works.

Here’s my stab at it. From this log I’m looking at the first and third attempts. (The second one failed because the mission needed to be reset.)

In both attempts you can see in the messages that the FC recorded the acceleration.


2021-12-23 15:56:17.698 Armed AUTO, xaccel = 17.4 m/s/s, waiting 0.2 sec
2021-12-23 15:56:19.999 Holding course 30671 at 6.2m/s (87.7)


2021-12-23 16:04:34.618 Armed AUTO, xaccel = 15.1 m/s/s, waiting 0.2 sec
2021-12-23 16:04:34.840 Triggered AUTO. GPS speed = 7.2

The difference is that within 0.2 seconds the plane must see it’s required minimum speed. When looking closely at the first attempt the plane was not at the required speed within the 0.2 seconds. But to be fair you must have been really close.


In the first attempt VS the third I noticed that the pitch seemed to be pretty high for a hand launch. In the first launch it’s pushing nearly 40, but the third successful attempt it tops out just about 25. That extra bit of climb is probably what’s slowing things down just that little bit that’s the difference between success or not.

My two cents worth: try and throw the plane at more level attitude. The speed is more important than any additional altitude you may get.

Wow - thanks @Allister - that explains a lot. This Bixler 2 kicks in a pretty heavy down thrust when it first powers up, so I have found I have to throw it very high otherwise it will just dive into the ground before it gets up enough speed to fly. So I guess I should just reduce the required minimum speed (maybe 5 m/s)?

Maybe. That could mean the thrust angle is wrong, or C of G off.

Bixlers have that high mounted prop. I’d seriously consider shake-to-wake. The motor is well clear of your hand. Add in some throttle slew so it’s got a moment to speed up and then give it a toss once you know the motor is running.

Edit: Just thinking outloud. If you’re not comfortable with throwing the plane with a spinning prop, maybe adding some throttle slew might be a good idea any way. The power won’t come on so sudden and might help with the pitching.

That might make more sense. It’s what I do when flying manually - fire up the motor before I chuck it.

Edit - maybe I should try throttle slew too. This is all a learning experience for me, so some experimentation might be good to do with this 'ol plane that is only about one crash away from the dump.

According to the messages the FC is recognizing the attempts:


2022-01-09 02:40:28.451 Armed AUTO, xaccel = 7.7 m/s/s, waiting 0.0 sec
2022-01-09 02:40:32.711 Armed AUTO, xaccel = 7.5 m/s/s, waiting 0.0 sec

I don’t think it’s seeing the speed. According to the wiki you could set MINSPD to 0, meaning it’s going to give it full beans right away. Personally, as I said to Tim, I’m a fan of the shake to wake.

Here’s a good primer:

There seems to be some other issues with this plane and the modes and tune. If you want some help with that might be worth starting another thread.

1 Like

Thanks @Allister I’ll take a look at the shake to wake, but I’m interested in your comment about the speed. I looked at ASPD in the UAViewer and it seemed to be displaying zero all the time. Should I be looking at a different place to see the airspeed?

The wiki says takeoff mode is using GPS speed, and the log messages I’ve been looking at correlate that. I’m guessing airspeed at that lower end of the scale may be a little unreliable for triggering the take off or subject to false starts.

1 Like

Hi @Allister I just saw your note about “other issues” and I could definitely use the help. Should I just start a new topic for this plane specifically?

No, that was for my reply to @WillemOdie . But if there’s other questions just go ahead and start a new thread.

1 Like

Guys thank you for the checks done.

In many autolaunch attempts, even with Tim’s log it seems the acceleration from the throw does not correspond with the spike in GPS speed in any cases. For me, I plan to first test with MINSPD=0 to test only with the acceleration. I have set the following and will test: TKOFF_THR_MINACC=5, TKOFF_THR_MINSPD=0 and TKOFF_THR_SLEW=20.

Edit - The setting above worked. I will update settings now to a tiny value for GPS speed (like 3km/h). At least I (think) what is going on now due to your help. Thank you kindly, from me and the EPO nose of my Skywalker.

Edit 2 - And if this is unsuccessful, I will use shake to wake, maybe even make use of TKOFF_ACCEL_CNT if needed. Cheers.



For me setting the min speed and the delay to zero was the crucial parameter change.
One precaution:

  • For safety reason just arm the plane immediately for the scheduled takeoff.

Good luck!!

If you try that it only needs to be 2 or 3. I like it because I can set my radio then I have a moment before I focus on the plane.

I just applied these lessons on a new plane and the auto takeoff worked perfectly first time - thank you!