Failsafe problem with X8R, MP or v4.05 (not sure)

Hi everyone,

I am not sure if it is a problem with my X8R, a change from 4.0.5 or a problem with Missionplanner.

First how I handled Failsafe until now:

Taranis: Failsafe mode “custom”, flight mode PWM for this setting is set to RTL
Missionplanner: Failsafe radio: Disabled.

That always worked and was tested sucessfull (Taranis switched off during flight). Flight mode always changed to RTL, also visible in ground station when disarmed.

So I copied all data for my new quad for another X8R and set up all values in missionplanner identically.

When I switch off my Taranis now, nothing changes. The PWM values always stay in the last position. I also tried to change the failsafe mode to “receiver” or “no pulses” and pushed the F/S button on my X8R. Still no PWM movement anymore after Taranis switch off, neither via PWM output nor via SBUS.

As an alternative to this, I activated radio failsafe PWM (MP) and now failsafe is dectected correctly. The strange thing is that it does not matter which failsafe mode I use in my taranis. Radio Failsafe always works. Then the other question is why is flight mode not changed to RTL? Is the show flight mode not correct when Failsafe is dectected?

Do you have an idea if my X8R is not working properly or if my setup for v4.05 is maybe wrong? As I said, I just copy and pasted all values from my older quad (Taranis and Pixhawk).