Failing to load parameters over telemetry radio

I recently set up an Omnibus F4 SD board and its failing to load parameters into Mission Planner when connected with any type of serial modem telemetry link. It loads parameters just fine when connected over USB. The live telemetry data stream seems to work well so I know the TX/RX is wired correctly. In QGC I get a warning saying “unable to retrieve full parameter set from vehicle” and in Mission Planner the parameter download progress bar just doesn’t move. Does anyone know of a reason why parameters would fail to load even though telemetry works? Thanks!

Do you set Ardupilot telemetry serial speed at 38400 (default is 57600?).


I have it set to 38400 because that’s what is recommended for DragonLink telemetry without flow control. I just tried increasing all the serial1_baud to 57600 along with the baud rate on my DL TX and RX and had the same result: live telemetry data works but no parameters.

Note I’ve also tested it with Sik telemetry radios with the same result

I was having this problem with an Omnibus F4 Nano V6.1 board and setting SERIAL1_OPTIONS to 4 (half duplex) seems to fix it. Parameters are slow to load, but they do load

I have the similar problem. I have tried with RFD900 and 3DR fpv telemetry radio. The same problem is there. no parameters loading on any baud rate. It is working with USB but not telemetry. Please help.

1 Like