"Failed to initialise ADNS3080" Problem

Hi, Been trying to set up an optical flow sensor on my APM 2.5. Both the CLI in mission planner and the python program say “Failed to initialise ADNS3080”. I’ve triple checked the wires. Any ideas? Lots of people seem to have had this problem but no-one has solved it…

Hello, I have the same issue I am afraid.

When I test the sensor (connected according to the guide on copter.ardupilot.com/wiki/optica … _the_APM25 ) I get “can’t init ADNS3080”.

When I flashed APM AC_3.2 I can not get the terminal to work. All I see as result when I click connect is random code (probably mavlink data).

I tried flashing older version of ArduCopter 2,9 and terminal works but still can’t init…
When I use the Pyton pde fail I get “can’t init ADNS3080” and also “can’t find first pixel”.


I am having exactly the same problem kindly any one help

Hi comrades.
Problems with ADNS3080 sensor more easy and more higher. If you are steel need help with this question, tell me here…

I’m currently having the exact same problem, did you ever find a solution?