Servers by jDrones

Failed in loading all parameters upon connection


(Bryce Bender) #1

Hello all,

So it appears that I am unable to fully get into Mission Planner. Mission Planner takes a very long to time to initialize all of the parameters. Is this normal for the first time?

Here is a video of exactly how I go about connecting to Mission Planner. I am trying to connect a PXFmini on a Pi3 to the GCS for first time set up. I have completed all of the necessary updates and installs on the Pi side of things.

I simply have both my laptop, and my Pi3 connected to the same wifi network, and then SSH into the Pi3 from my laptop prior to connecting to Mission Planner. The folks at Erle Robotics suggested signing into mission planner with the IP of my laptop, and using port 6000.
Note: This process takes between 8-10 minutes, loading very slowly each parameter until it fails. For time sake, I paused the video and restarted it again each time it began initializing a new parameter.

Please let me know if you see anything that I am obviously doing wrong in the video, or if you have troubleshooting suggestions. All help is welcome!

Regards,
@BryceBender


(mike kelly) #2

Via a 115K serial connection it would only take 30-45 sec. So I would look at something on your laptop-antivirus checker, defender or something choking the bandwidth.


(Bryce Bender) #3

@mike, thanks for your comment.

I figured out that the connection failure was rooted in poor GPIO pin connection from the Pi to the PXFmini. I have since been able to successfully calibrate the RC and accelerometer. When going to calibrate the motors and ESCs the LEDs flash in the expected pattern for ESC calibration mode but are not calibrating. Here is a video of exactly what I see.

What could be causing this type of behavior?

Thanks for any and all advice!
@Bryce_Bender


(mike kelly) #4

It almost sounds to me like the ESC’s were giving an error code. You hear the normal beep and then another sound. The error codes are all unqiue to each brand of ESC. I have had trouble getting the ESC cal to work in the past on a couple of aircraft. So you have the alternative of doing the cal right out of your receiver or you can force Ardupilot into calibration mode. There is a parameter, that Ardupilot is supposed to set after the first detection of power-on with throttle-high, that tells it to do a calibration on the next power up. But some times it does not detect it properly. It is not recommended but I have manually set that parameter to get it to go into ESC cal. I can’t seem to find in the full parameter list at the moment.

Althought somewhat of a religious issue the ground wire for the ESC signal appears to be needed on some ESC’s. I have never used a ground wire and I have never had a problem with many builds but some people do appear to have a problem if they don’t connect the ground wire.

https://pixhawk.org/users/actuators/pwm_escs_and_servos


(Bryce Bender) #5

@mike, I appreciate your feedback!

I neglected previously to state I am using RCTimer 30A OPTO ESC’s found here.

The Mission Planner parameter you are talking about appears to be met already because I can see the expected flashing of the autopilots LEDs as explained by PXFmini documentation.

So, if the parameter on the autopilot is being met (as assumed by the expected LED lighting as explained by this) then I believe your second hypothesis might be correct, that there is some sort of error or issue with the ESC’s.

Despite that the ESC’s are OPTO, could it be of any use to remove the red wire on my ESC’s?

How could I go about troubleshooting that error?

Thanks,
@Bryce_Bender


(mike kelly) #6

Unfortunately the term “Opto” was appropraited and is not used correctly in this context. Opto is short for optically isolated and concerns creating a signal connection via a lightbeam rather than a copper circuit. But in this context it simply means there is no BEC built into the ESC.

You should remove the red wire if your ESC have a BEC so that, which the OPTO designator indicates they should not, the multiple BEC don’t “fight” each other.

Otherwise only the manufacturers documentation can describe what their beep codes mean.

Worse comes to worse just cal the ESC’s directly from the receiver.


(Bryce Bender) #7

Thanks @mike,
Can you explain what you mean by calibrating directly from the receiver?
Thanks,
@Bryce_Bender


(mike kelly) #8

You can do things the manual way when needed.

  1. The ESC’s need to know what the range of PWM values your radio stick provides.
    Connect the ESC’s to your receiver’s PWM outputs directly, if it has them, and do the calibration without the Pixhawk in the picture.

  2. Make sure the min and max PWM values are what you want in Arducopter by going into the MOT_ parameters and manual set the minimum and maximum values if needed.


(Bryce Bender) #9

Thanks for the pointer @mike.

I have done this, and I successfully calibrated each ESC & motor combo! Thanks for the help. The problem I have now is when I plug the receiver back into the PWM --> PPM converter, and the PPM, +, & - cables into the PPM port in my PXFmini, and then I plug the ESC cables into their respective ports on the PXFmini I get no response from my quad when I power on the RC transmitter and throttle up, or try and enable the quad.

How could this be?

I know that the PPM converter is passing power down to my RX because its LED is illuminated and responds when the TX is turned on, but is it possible that the PPM converter isn’t compatible, or flawed somehow keeping the signal from getting to the AutoPilot? This is the PPM encoder I have on my build PPM encoder.

Can you suspect any other potential causes for this problem?

Thanks,
@Bryce_Bender


(mike kelly) #10

Do you “see” the radio in the radio cal page of mission planner? When you move the sticks do the green bars move?

Has this worked before or something change?


(Bryce Bender) #11

@mike, Yes this works, and the radio calibration works with the PPM encoder plugged in, so I guess the debunks my prediction.

Do you have any other hypothesis on what could be the matter?

Thanks!!


(mike kelly) #12

So go into the messages under the HUD in mission planner and see what the problem is … mostly likely a pre-arm check not being met.


(Bryce Bender) #13

Thanks for the tip @Mike, the HUD had the pre-arm requirement of “compass not calibrated.” After calibrating the compass, I see no messages other than the occasional, “initialising APM”

My AutoPilot is flashing its LEDs in the cyclical pattern saying that it is in ESC calibration mode. When I go through the ESC all in one calibration set up, it doesn’t work. I feel like I’ve come full circle and I am at the same problem.

Any other pointers/tips/questions are greatly appreciated!


(mike kelly) #14

I would guess that you are stuck with the ESC cal parameter turned on but unable to complete the cal to reset the parameter. So I would just turn it off manually. I am not near a windows machine but I am sure you can find it if you search the full parameter list for “ESC”.


(Bryce Bender) #15

Thanks for the idea. Where do I go to see the parameters list?
Just to verify, when I go to the calibration page in Mission Planner, I simply select NORMAL for the ESC type, and everything else I leave standard. Would you recommend doing it any other way?


(mike kelly) #16

I never calibrate using Mission Planner so I could not tell you off the top of my head.

You will find the parameters on the config tuning page. Everything you do, even if it has a convenient GUI like the initial setups, actually sets parameters. So you can set parameters directly once you get to know them. There are a number of ways to “look” at the parameters but go to the full parameter list which has a “find or search box” on the left side of the screen. Type in “ESC” and look for the parameter that sets the FC into ESC cal mode. I suspect it is enabled and you want to turn that parameter off to get out of ESC cal mode.

Once you change the value of the parameter be sure to click on the “write” button.

I finally found the parameter:
ESC_CALIBRATION: ESC Calibration
Note: This parameter is for advanced users

Controls whether ArduCopter will enter ESC calibration on the next restart. Do not adjust this parameter manually.
Values
Value Meaning
0 Normal Start-up
1 Start-up in ESC Calibration mode if throttle high
2 Start-up in ESC Calibration mode regardless of throttle
3 Start-up and automatically calibrate ESCs
9 Disabled