F405-WING:how to cnnect the ExpressLRS recevicer(use crsf protocol)

I use the F405-wing FC(firmwaire arduplane_with_bl4.1.7.hex),and use the serial 1 to connect the elrs nano recevicer. And I’m sure the hardware connect is correct.
Ardupilot setup like this:
Uploading: 2.jpg…

Are there any other parameters that I need to be set?

I measured the FC’s serial1 with the oscilloscope. The RXD had the signals ,but the txd whitout any signals. So I think maybe the parameters I set are worng.

RC_PROTOCOLS can just be “1”. (Incidentally, 513 is 1+512 so you’ve already enabled all the protocols.) Or you could try it with just 512.

RSSI_TYPE should be 3. And you might want to enable bits 8 and 9 in RC_OPTIONS.

Does the radio configuration page in mission planner show movement when you move the TX sticks? Are you sure the TX is set up properly (do you have other ELRS models that it works with)?

I set the RC_PROTOCOLS at 1,and RSSI_TYPE at 3.If I move the TX sticks,the radio configuration page still not work.

But I have a question of RC_OPTIONS。
Am I right of RC_OPTIONS?

I’m not an expert but that looks right to me.

Have you tested the TX with any other ELRS models? Just wondering if it could be a TX issue.

Thanks for U help, I’ve solved it ,I change the recevicer to connnect the FC‘s serial4 replace serial1,and it work normal.