F405-CTR: Suggested UART order mandatory?

I’m making a first attempt/test at ArduCopter by trying to convert a small quad so far running INAV, rewiring as little as possible in case I want to go back.

However, I cannot get the GPS to work so far (no data), which was already connected and working in INAV, but to a different UART than suggested here: https://ardupilot.org/copter/docs/common-matekf405.html#default-uart-order (I have it on UART 3.)

So my simple question is if it’s necessary to switch GPS to UART 1 to make it work on F405-CTR even though it also says it “can be adjusted to personal preferences”.


EDIT: A second question came up - it looks like I would also have to rewire the motors as per https://ardupilot.org/copter/docs/connect-escs-and-motors.html ?

You don’t have to rewire the motors just remap them. Use Mission Planners Motor Test feature and then adjust the servo mapping to correct it. You may have to change the motor direction also the test is good for this too.

First make sure the board orientation is correct by pitching and rolling the craft while looking at the HUD in Mission Planner. If this is wrong correct it with the board orientation parameter.

Thanks. Unfortunately on activating motor test I got a neverending beep from the buzzer, so I couldn’t proceed any further. It’s probably some kind of warning that should be disabled first?

If you are using mission planner do you get any logging output?

I currently have the quad back on INAV to investigate an unrelated problem, but I took out the sd card and the APM/LOGS folder is completely empty. APM still contains ArduCopter.bak, so I don’t think INAV has killed any logs that were previously there. I should probably take a look at LOG_BITMASK next time I have AC on it?

Note that I haven’t really started the basic setup, for now I was merely just trying to find out what I’d have to change physically to be able to move back and forth between INAV and AC just by changing the software.