Extreme jittering servo output only aileron tab in ardupilot

i use pixhawk 4 and 2 for my fixed wing, everything seems fine with manual mode even when arming, but suddenly when i change it to FBWA, STIBILIZE, and AUTOTUNE mode it get jittering especially on aileron, the pixhawk got so sensitive also when i arming the plane in the GCS it got more extremly jittering, what should i do? everything seems fine, the parameter, the PID, bank max, i already do the callibration compas, remote, and the pixhawk too, even i reseted the both pixhawk is it because of the firmware? please help thank you.


Those are all GPS controlled modes, so indoors you may be getting jitter or noise from the GPS module that is trying to position the plane but can’t because it doesn’t have a solid position. Try it out side with a good GPS lock and low HDOP on mission planner and see if the problem goes away. If the problem continues you’ll need to look for other sources of noise.

1 Like

Yesterday i already tried outside it still jittering, but maybe i’ll try again today, i’ll tell later you when i’ m done, thanks for your respons

Excuse me sir, i already uploaded a video using gps mode outside, but still jittering in those drive link, you can check it, thank you

I have the same issue on arduplane 4.1.2

I tried to change the rc receiver, no change. I have 2 gps receivers in the plane.

Is it possible to have this issue because of this?