Excecuting GLOBAL erase on Pixhawk

Hey everyone I started having some weird issues with my pixhawk a couple of weeks ago since then the issues have been getting worse icluding weird bugs etc. I’m suspecting something went wrong in the FW side. I tried reseting it by flashing arduplane and going back to AC. However that didn’t do mutch.
Does anyone know a way to do a GLOBAL erase on pixhawk??

Go to the Full Parameter View in APM Planner 2.0 or Mission Planner and select ‘reset to defaults’

This won’t do, I’ve tried it, the bug seems to lie deeper. I want a way to totaly delete any firmware on board.

That’s a full reset. Flash new firmware and do that (well I know AP2 does that).
Otherwise it would be more HW related issue you are seeing.

I tried doing what you said and now I get this!
When ever trying to connect to terminal pixhawk starts sending junk. See the photo below

Ok flashing back to AC 3.2 seems to have fixed it. Will try to load 3.3 and see

Nope still the same on 3.3… Will run 3.2.1 for now

That’s correct, that the MAVLink Protocol. Here’s mine that is working.

Init APM:Copter V3.3 (340970fc)

Free RAM: 45168
FW Ver: 120

load_all took 254us
0 0 0 � Q}��3�Initialising APM...�}�3�Calibrating barometerz��  QC^�3�barometer calibration complete��3�GROUND START��Init Gyro*�     Q�****� Q�
G_off: 0.01, 0.02, -0.04
A_off: 0.00, 0.00, 0.00
A_scale: 1.00, 1.00, 1.00

Ready to FLY  ublox �  Q��              Q���
QH3�    Qv��    Q���    Q���    QE��    Q{z     Q�C�    Q%=�    Q�M�

but I can’t use any commands and it keeps going like that forever

and it’s the first time I see that happening, none of my other quads running older FW’s do that

There Terminal Mode has been disabled since AC3.2.

Oh ok I see, thanks for the help !