Esc configurator cannot connect to Matek H743 Wing

I have used for a while, it works fine with Matek F405-WMN fc. However I can’t get the configurator connect to Matek H743 Wing.
I had tried creating an issue here
Cannot connect to matek H743 wing, saying Port already in use by another application - try re-connecting · Issue #327 · stylesuxx/esc-configurator · GitHub
Looks that the difference between H743 one and F405 one is that the H743 has two com ports
while F405 only has one
It haven’t got to setting pass through parameters, it failed at step of connecting configurator to fc.

Disconnect Mission Planner, first. Use the port labeled MavLink.

I’ve already disconnected MP, and tried both COM6 and COM7. So for other F7 and H7 FCs, the port labeled MavLink, COM6 in my case should the esc configurator connect to? For Matek H743 Wing v3, it doesn’t work.

Unfortunately the BLHeli passthrough code is extremely fragile and very dependent on flight controller and ESCs. I have never been able to get the configurator to work reliably but have not had the time to dig in