ESC calibration - not sure if done correctly


I have a quad-copter with an omnibus F4V6 installed on it (with ardupilot loaded) and I am having trouble doing the ESC calibration. My ESC is a 4 in 1 blHeli 60A ESC. So to calibrate it, I plug in the usb, connect to missionplanner, go to the calibration tab, and click calibrate. Then, I unplug the usb and plug in the battery. I do not hear a motor tone when I plug in the battery that is supposed to tell me to unplug it, instead it goes straight to calibration and it doesn’t matter how I place my throttle stick it does the calibration on it’s own, even though I have the min and max PWM set to 0. I am using the normal setting for the esc type, haven’t tried others.

I tested the motors at 5% throttle and they were turning very fast for 5%, I don’t think it should turn that fast. Also tested the motor response to moving the drone when it’s armed and on stabilize mode, and it doesn’t respond that much. I tried powering on the quad and it just spiraled out of control, here’s a video:

Thankfully it’s not totally broken, I suspect the problem is the ESC not properly calibrated.

Try plugin in the usb and the battery first together.

what do you mean? I tried that already and it says on the mission planner display 16v when I plug in the battery. All seems to be working, even the HUD displays the accelerometer correctly…

Mate, you should use BlHeliSuite to do the ESC calibration, not Mission Planner. If you have them set up for plain PWM.
If running something-Shot, no calibration is necessary.

Plug in the battery and the usb then run MP esc cal. Unplug the USB and battery, then plug in the battery the led will flash red and hit he Arm switch. The esc’s will make a happy noise and your all set. If the motor powerup in full power please let me know.